network bridge - unconnected

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

network bridge - unconnected

Marc Dumontier
Hi

I have a store and forward configuration setup...If i start the producer thread while the server  (where the network connector connects to) isn't up..the embedded broker from the producer never connects up with it.

2006-08-05 21:31:38,473 INFO [org.apache.activemq.broker.BrokerService] - ActiveMQ 4.0-RC2 JMS Message Broker (localhost) is starting
2006-08-05 21:31:38,473 INFO [org.apache.activemq.broker.BrokerService] - For help or more information please see: http://incubator.apache.org/activemq/
2006-08-05 21:31:38,569 INFO [org.apache.activemq.store.jdbc.JDBCPersistenceAdapter] - Database driver recognized: [mysql-ab_jdbc_driver]
2006-08-05 21:31:38,988 INFO [org.apache.activemq.network.NetworkConnector] - Establishing network connection between from vm://localhost?network=true to failover:tcp://localhost:9000
2006-08-05 21:31:38,999 INFO [org.apache.activemq.transport.vm.VMTransportFactory] - binding to broker: localhost
2006-08-05 21:31:39,016 INFO [org.apache.activemq.broker.TransportConnector] - Connector vm://localhost Started
2006-08-05 21:31:39,080 INFO [org.apache.activemq.network.DemandForwardingBridge] - Starting a network connection between vm://localhost#0 and unconnected has been established.
2006-08-05 21:31:39,133 INFO [org.apache.activemq.network.NetworkConnector] - Network Connector bridge Started
2006-08-05 21:31:39,133 INFO [org.apache.activemq.broker.BrokerService] - ActiveMQ JMS Message Broker (localhost) started

is there any way to make it so that the embedded broker keeps trying?

here is my relevant config


        <networkConnectors>
      <networkConnector uri="static:(tcp://localhost:9000)" failover="true"/>
    </networkConnectors>
   
Reply | Threaded
Open this post in threaded view
|

Re: network bridge - unconnected

James Strachan-2
Have you specified failover="true"?

http://incubator.apache.org/activemq/networks-of-brokers.html

On 8/6/06, Marc Dumontier <[hidden email]> wrote:

>
> Hi
>
> I have a store and forward configuration setup...If i start the producer
> thread while the server  (where the network connector connects to) isn't
> up..the embedded broker from the producer never connects up with it.
>
> 2006-08-05 21:31:38,473 INFO [org.apache.activemq.broker.BrokerService] -
> ActiveMQ 4.0-RC2 JMS Message Broker (localhost) is starting
> 2006-08-05 21:31:38,473 INFO [org.apache.activemq.broker.BrokerService] -
> For help or more information please see:
> http://incubator.apache.org/activemq/
> 2006-08-05 21:31:38,569 INFO
> [org.apache.activemq.store.jdbc.JDBCPersistenceAdapter] - Database driver
> recognized: [mysql-ab_jdbc_driver]
> 2006-08-05 21:31:38,988 INFO [org.apache.activemq.network.NetworkConnector]
> - Establishing network connection between from vm://localhost?network=true
> to failover:tcp://localhost:9000
> 2006-08-05 21:31:38,999 INFO
> [org.apache.activemq.transport.vm.VMTransportFactory] - binding to broker:
> localhost
> 2006-08-05 21:31:39,016 INFO [org.apache.activemq.broker.TransportConnector]
> - Connector vm://localhost Started
> 2006-08-05 21:31:39,080 INFO
> [org.apache.activemq.network.DemandForwardingBridge] - Starting a network
> connection between vm://localhost#0 and unconnected has been established.
> 2006-08-05 21:31:39,133 INFO [org.apache.activemq.network.NetworkConnector]
> - Network Connector bridge Started
> 2006-08-05 21:31:39,133 INFO [org.apache.activemq.broker.BrokerService] -
> ActiveMQ JMS Message Broker (localhost) started
>
> is there any way to make it so that the embedded broker keeps trying?
>
> here is my relevant config
>
>
>         <networkConnectors>
>       <networkConnector uri="static:(tcp://localhost:9000)"
> failover="true"/>
>     </networkConnectors>
>
> --
> View this message in context: http://www.nabble.com/network-bridge---unconnected-tf2057651.html#a5669323
> Sent from the ActiveMQ - User forum at Nabble.com.
>
>


--

James
-------
http://radio.weblogs.com/0112098/
Reply | Threaded
Open this post in threaded view
|

Re: network bridge - unconnected

Marc Dumontier
yes i have

here is the scenario

I have 3 processes.

process #1 - Producer
process #2 - ActiveMQ server
process #3 - Consumer


i run process #1, which sends 10 jms messages to an embedded broker (using vm://)

i run process #2 (connection is made between process #1 and process #2)

i kill process #1

i run process #3 - no messages are available from process #2


when i leave process #1 running, process #3 can consume the messages.

What I think I need is not a DemandForwardingBridge, but a ForwardBridge, where once the connection is made, the messages are forwarded to the remote broker regardless of any consumers.

I'm not sure how to accomplish this

Marc