[jira] Created: (AMQ-2856) m2eclipse fails to update maven project configuration

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[jira] Created: (AMQ-2856) m2eclipse fails to update maven project configuration

JIRA jira@apache.org
m2eclipse fails to update maven project configuration
-----------------------------------------------------

                 Key: AMQ-2856
                 URL: https://issues.apache.org/activemq/browse/AMQ-2856
             Project: ActiveMQ
          Issue Type: Bug
         Environment: ubuntu 10.4, java6, eclipse 3.4, m2eclipse  0.10.2.20100623-1649
            Reporter: Norman Maurer
         Attachments: activemq-assembly-pom.diff

If you try to "Update Project Configuration" via m2eclipse plugin you see the following error:

[ERROR] 'dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version (?) @ org.apache.activemq:apache-activemq:5.4-SNAPSHOT, /home/maurer/workspace2/activemq-trunk/assembly/pom.xml

This is caused because the dependecy of org.osgi.core is specified two times (with different qualifiers). m2eclipse is really strict on that.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply | Threaded
Open this post in threaded view
|

[jira] Updated: (AMQ-2856) m2eclipse fails to update maven project configuration

JIRA jira@apache.org

     [ https://issues.apache.org/activemq/browse/AMQ-2856?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Norman Maurer updated AMQ-2856:
-------------------------------

    Attachment: activemq-assembly-pom.diff

This patch fix the issue

> m2eclipse fails to update maven project configuration
> -----------------------------------------------------
>
>                 Key: AMQ-2856
>                 URL: https://issues.apache.org/activemq/browse/AMQ-2856
>             Project: ActiveMQ
>          Issue Type: Bug
>         Environment: ubuntu 10.4, java6, eclipse 3.4, m2eclipse  0.10.2.20100623-1649
>            Reporter: Norman Maurer
>         Attachments: activemq-assembly-pom.diff
>
>
> If you try to "Update Project Configuration" via m2eclipse plugin you see the following error:
> [ERROR] 'dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version (?) @ org.apache.activemq:apache-activemq:5.4-SNAPSHOT, /home/maurer/workspace2/activemq-trunk/assembly/pom.xml
> This is caused because the dependecy of org.osgi.core is specified two times (with different qualifiers). m2eclipse is really strict on that.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply | Threaded
Open this post in threaded view
|

[jira] Resolved: (AMQ-2856) m2eclipse fails to update maven project configuration

JIRA jira@apache.org
In reply to this post by JIRA jira@apache.org

     [ https://issues.apache.org/activemq/browse/AMQ-2856?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Dejan Bosanac resolved AMQ-2856.
--------------------------------

         Assignee: Dejan Bosanac
    Fix Version/s: 5.4.0
       Resolution: Fixed

OSGi dependency removed altogether as it's not included in the distro anymore.

> m2eclipse fails to update maven project configuration
> -----------------------------------------------------
>
>                 Key: AMQ-2856
>                 URL: https://issues.apache.org/activemq/browse/AMQ-2856
>             Project: ActiveMQ
>          Issue Type: Bug
>         Environment: ubuntu 10.4, java6, eclipse 3.4, m2eclipse  0.10.2.20100623-1649
>            Reporter: Norman Maurer
>            Assignee: Dejan Bosanac
>             Fix For: 5.4.0
>
>         Attachments: activemq-assembly-pom.diff
>
>
> If you try to "Update Project Configuration" via m2eclipse plugin you see the following error:
> [ERROR] 'dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version (?) @ org.apache.activemq:apache-activemq:5.4-SNAPSHOT, /home/maurer/workspace2/activemq-trunk/assembly/pom.xml
> This is caused because the dependecy of org.osgi.core is specified two times (with different qualifiers). m2eclipse is really strict on that.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.