error in /admin/xml/queues.jsp

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

error in /admin/xml/queues.jsp

Adam Whitney
We just upgraded from 5.13.3 to 5.14.5 and now when we try to get queue stats form /admin/xml/queues.jsp we get a page with the following errors:

This page contains the following errors:

error on line 4 at column 666: Namespace prefix c on forEach is not defined
error on line 5 at column 14: Unescaped '<' not allowed in attributes values
Below is a rendering of the page up to the first error.


There is nothing below the error message. Is this a known regression in 5.14.5?
Reply | Threaded
Open this post in threaded view
|

Re: error in /admin/xml/queues.jsp

Tim Bain
This is the first time it's been reported to the mailing list.

Are you able to narrow down what's required to make it happen? For example,
can you reproduce it after a broker restart? Can you reproduce it in a
broker that has consumers attached but no messages published yet (and none
in the persistence store)? Can you reproduce it with only one consumer and
one queue (and still no messages)? How about with no consumers at all (and
therefore no queues)?

The more you're able to narrow down the factors that contribute to the
occurrence of the problem, the faster it's likely to get fixed.

Tim

On May 16, 2017 5:28 PM, "Adam Whitney" <[hidden email]> wrote:

> We just upgraded from 5.13.3 to 5.14.5 and now when we try to get queue
> stats
> form /admin/xml/queues.jsp we get a page with the following errors:
>
> /This page contains the following errors:
>
> error on line 4 at column 666: Namespace prefix c on forEach is not defined
> error on line 5 at column 14: Unescaped '<' not allowed in attributes
> values
> Below is a rendering of the page up to the first error./
>
> There is nothing below the error message. Is this a known regression in
> 5.14.5?
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.
> nabble.com/error-in-admin-xml-queues-jsp-tp4726220.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: error in /admin/xml/queues.jsp

rockies
In reply to this post by Adam Whitney
I see the same exact error after upgrading to version 5.14.5 and JDK 1.8.0_131. This happens when I try to get XML version of Queues and Topics in ActiveMQ Web Console. Looks like this is related to JSTL libs. Do I need to add other jars during install ?
Reply | Threaded
Open this post in threaded view
|

Re: error in /admin/xml/queues.jsp

Tim Bain
Not that I'm aware of; I don't remember seeing any such requirement in the
release notes (and I'd be surprised if there was one, since we typically
bundle all necessary JARs). What version were you upgrading from?

Can one of you please write a bug in JIRA for this?

Thanks,
Tim

On Mon, May 22, 2017 at 9:49 PM, rockies <[hidden email]> wrote:

> I see the same exact error after upgrading to version 5.14.5 and JDK
> 1.8.0_131. This happens when I try to get XML version of Queues and Topics
> in ActiveMQ Web Console. Looks like this is related to JSTL libs. Do I need
> to add other jars during install ?
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.
> nabble.com/error-in-admin-xml-queues-jsp-tp4726220p4726435.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: error in /admin/xml/queues.jsp

Adam Whitney
I'm also using Java 1.8 ... with both 5.13.3 and 5.14.5

Also, to Tim's earlier request, I deleted all the queues (using the /admin/queues.jsp page) and still got the same error when I went to the /admin/xml/queues/jsp page.

I'll filed a JIRA: https://issues.apache.org/jira/browse/AMQ-6685
Reply | Threaded
Open this post in threaded view
|

Re: error in /admin/xml/queues.jsp

Adam Whitney
This post was updated on .
In case anyone needs a workaround ... we were using the /admin/xml/queues.jsp page to get stats from ActiveMQ into splunk for monitoring and alerting. We've worked around the issue by using the jolokia endpoint, e.g.:

/api/jolokia/read/org.apache.activemq:type=Broker,brokerName=*,destinationName=*,destinationType=Queue
Reply | Threaded
Open this post in threaded view
|

Re: error in /admin/xml/queues.jsp

christopher.l.shannon
This has been fixed as part of AMQ-6656 which AMQ-6685 duplicated.  The fix
will be part of 5.15.0 (and 5.14.6 if a release is done)

On Wed, May 24, 2017 at 10:22 AM, Adam Whitney <[hidden email]>
wrote:

> one thing to note ... we were using the /admin/xml/queues.jsp page to get
> stats from ActiveMQ into splunk for monitoring and alerting. We've worked
> around the issue by using the jolokia endpoint, e.g.:
>
> /api/jolokia/read/org.apache.activemq:type=Broker,
> brokerName=*,destinationName=*,destinationType=Queue
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.
> nabble.com/error-in-admin-xml-queues-jsp-tp4726220p4726479.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>