cannot send channel has already failed

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

cannot send channel has already failed

shekharnaidu
I am doing my application setup in linux for the first time. I have both a
standalone java program and active mq running on Linux.
I am trying to connect to Active Mq (5.13) but I keep getting an error
message "*cannot send channel has already failed*"

The same program working fine in my local windows machine (when I run
standalone java & active mq in my local).

Please advise.

--
Shekhar
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: cannot send channel has already failed

Tim Bain
I've never seen that error be the first error to occur; in my experience,
there has always been something else that failed, and then you hit the
error you quoted. Are there any earlier errors in your log files (either
client or broker)?

Tim

On Mar 31, 2017 5:36 AM, "Shekhar Naidu" <[hidden email]> wrote:

I am doing my application setup in linux for the first time. I have both a
standalone java program and active mq running on Linux.
I am trying to connect to Active Mq (5.13) but I keep getting an error
message "*cannot send channel has already failed*"

The same program working fine in my local windows machine (when I run
standalone java & active mq in my local).

Please advise.

--
Shekhar
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: cannot send channel has already failed

shekharnaidu
I do not see any other issues/exceptions except this one

Thank you
Shekar

On Mar 31, 2017 9:27 AM, "Tim Bain" <[hidden email]> wrote:

> I've never seen that error be the first error to occur; in my experience,
> there has always been something else that failed, and then you hit the
> error you quoted. Are there any earlier errors in your log files (either
> client or broker)?
>
> Tim
>
> On Mar 31, 2017 5:36 AM, "Shekhar Naidu" <[hidden email]> wrote:
>
> I am doing my application setup in linux for the first time. I have both a
> standalone java program and active mq running on Linux.
> I am trying to connect to Active Mq (5.13) but I keep getting an error
> message "*cannot send channel has already failed*"
>
> The same program working fine in my local windows machine (when I run
> standalone java & active mq in my local).
>
> Please advise.
>
> --
> Shekhar
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: cannot send channel has already failed

shekharnaidu
I am seeing connection reset errors in the active mq log file.

On Mar 31, 2017 3:23 PM, "Shekhar Naidu" <[hidden email]> wrote:

> I do not see any other issues/exceptions except this one
>
> Thank you
> Shekar
>
> On Mar 31, 2017 9:27 AM, "Tim Bain" <[hidden email]> wrote:
>
>> I've never seen that error be the first error to occur; in my experience,
>> there has always been something else that failed, and then you hit the
>> error you quoted. Are there any earlier errors in your log files (either
>> client or broker)?
>>
>> Tim
>>
>> On Mar 31, 2017 5:36 AM, "Shekhar Naidu" <[hidden email]> wrote:
>>
>> I am doing my application setup in linux for the first time. I have both a
>> standalone java program and active mq running on Linux.
>> I am trying to connect to Active Mq (5.13) but I keep getting an error
>> message "*cannot send channel has already failed*"
>>
>> The same program working fine in my local windows machine (when I run
>> standalone java & active mq in my local).
>>
>> Please advise.
>>
>> --
>> Shekhar
>>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: cannot send channel has already failed

Tim Bain
Connection reset errors mean that the far side (i.e. the client in this
case) closed the connection. So those aren't the root cause of the behavior
you're seeing.

Is there any chance that a firewall or antivirus program could be
interfering with this traffic? That's the only thing I can think of that
would result in closed network connections without errors on either side.

If not, since neither log is showing what the underlying problem is, I see
two things you could do:
1. Turn up logging to DEBUG and see if you can see anything useful then.
2. Download the ActiveMQ source, attach a debugger, and walk through the
code to try to figure out what's going on.

Tim

On Mar 31, 2017 1:25 PM, "Shekhar Naidu" <[hidden email]> wrote:

> I am seeing connection reset errors in the active mq log file.
>
> On Mar 31, 2017 3:23 PM, "Shekhar Naidu" <[hidden email]> wrote:
>
> > I do not see any other issues/exceptions except this one
> >
> > Thank you
> > Shekar
> >
> > On Mar 31, 2017 9:27 AM, "Tim Bain" <[hidden email]> wrote:
> >
> >> I've never seen that error be the first error to occur; in my
> experience,
> >> there has always been something else that failed, and then you hit the
> >> error you quoted. Are there any earlier errors in your log files (either
> >> client or broker)?
> >>
> >> Tim
> >>
> >> On Mar 31, 2017 5:36 AM, "Shekhar Naidu" <[hidden email]>
> wrote:
> >>
> >> I am doing my application setup in linux for the first time. I have
> both a
> >> standalone java program and active mq running on Linux.
> >> I am trying to connect to Active Mq (5.13) but I keep getting an error
> >> message "*cannot send channel has already failed*"
> >>
> >> The same program working fine in my local windows machine (when I run
> >> standalone java & active mq in my local).
> >>
> >> Please advise.
> >>
> >> --
> >> Shekhar
> >>
> >
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: cannot send channel has already failed

shekharnaidu
The problem got resolved when I set the keepalive=true on the client and
broker.

On Apr 2, 2017 10:26 AM, "Tim Bain" <[hidden email]> wrote:

> Connection reset errors mean that the far side (i.e. the client in this
> case) closed the connection. So those aren't the root cause of the behavior
> you're seeing.
>
> Is there any chance that a firewall or antivirus program could be
> interfering with this traffic? That's the only thing I can think of that
> would result in closed network connections without errors on either side.
>
> If not, since neither log is showing what the underlying problem is, I see
> two things you could do:
> 1. Turn up logging to DEBUG and see if you can see anything useful then.
> 2. Download the ActiveMQ source, attach a debugger, and walk through the
> code to try to figure out what's going on.
>
> Tim
>
> On Mar 31, 2017 1:25 PM, "Shekhar Naidu" <[hidden email]> wrote:
>
> > I am seeing connection reset errors in the active mq log file.
> >
> > On Mar 31, 2017 3:23 PM, "Shekhar Naidu" <[hidden email]> wrote:
> >
> > > I do not see any other issues/exceptions except this one
> > >
> > > Thank you
> > > Shekar
> > >
> > > On Mar 31, 2017 9:27 AM, "Tim Bain" <[hidden email]> wrote:
> > >
> > >> I've never seen that error be the first error to occur; in my
> > experience,
> > >> there has always been something else that failed, and then you hit the
> > >> error you quoted. Are there any earlier errors in your log files
> (either
> > >> client or broker)?
> > >>
> > >> Tim
> > >>
> > >> On Mar 31, 2017 5:36 AM, "Shekhar Naidu" <[hidden email]>
> > wrote:
> > >>
> > >> I am doing my application setup in linux for the first time. I have
> > both a
> > >> standalone java program and active mq running on Linux.
> > >> I am trying to connect to Active Mq (5.13) but I keep getting an error
> > >> message "*cannot send channel has already failed*"
> > >>
> > >> The same program working fine in my local windows machine (when I run
> > >> standalone java & active mq in my local).
> > >>
> > >> Please advise.
> > >>
> > >> --
> > >> Shekhar
> > >>
> > >
> >
>
Loading...