cannot build 4.0.2 source

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

cannot build 4.0.2 source

igah
when i tried to build 4.0.2 with maven (1.0.2), i got errors like the following:

Attempting to download derby-10.1.1.0.jar.
Error retrieving artifact from [http://www.ibiblio.org/maven/org.apache.derby/jars/derby-10.1.1.0.jar]: java.io.IOException: Unknown error downloading; status code was: 301
WARNING: Failed to download derby-10.1.1.0.jar.

i searched internet and found some posts about maven repository being moved. i tried to add

http://mirrors.ibiblio.org/pub/mirrors/maven

to maven.repo.remote in project.properties. but got the same error. maven doesn't seem to take it? could anyone help me out? i am not very familar with maven.

thanks in advance.
Reply | Threaded
Open this post in threaded view
|

Re: cannot build 4.0.2 source

igah
i found out why. i need to apply the same change to all the project.properties files under each sub-directory.

the build still failed because it couldn't find activemq-core-test-4.0.2.jar from ibiblio. i temporarily commented out the dependency and now it builds at least...

igah wrote
when i tried to build 4.0.2 with maven (1.0.2), i got errors like the following:

Attempting to download derby-10.1.1.0.jar.
Error retrieving artifact from [http://www.ibiblio.org/maven/org.apache.derby/jars/derby-10.1.1.0.jar]: java.io.IOException: Unknown error downloading; status code was: 301
WARNING: Failed to download derby-10.1.1.0.jar.

i searched internet and found some posts about maven repository being moved. i tried to add

http://mirrors.ibiblio.org/pub/mirrors/maven

to maven.repo.remote in project.properties. but got the same error. maven doesn't seem to take it? could anyone help me out? i am not very familar with maven.

thanks in advance.