basic setup, topic with more subscribers

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

basic setup, topic with more subscribers

jana

hi

 

Im trying my way around activemq and stomp for PHP connectivity. Its a clean, fresh install - I only enabled stomp/nio and thats it. Then I created a producer and two consumers both sending ID (different) and then running it all.

 

the producer is sending OK but the strange thing is that the consumers are only getting every 2. msg.

 

If the producer is sending to /topic/test msg.:

 

test1

test2

test3

test4

 

then the first consumer is getting test1 and test3 and the 2. is getting test2 and test4

 

I would think thats a queue and using a topic both constumers shoudl get all 4 msg? Is this not the expected behavior? Or does this not work with stomp (the client is 1.0 it seams activemq is 5.6) or do I still need some configuration on the MQ to make it work?

 

thanks and best regards
Jan

 

 

Reply | Threaded
Open this post in threaded view
|

Re: basic setup, topic with more subscribers

Brian McCallister
Your best bet is probably to ask on the activemq mailing list http://activemq.apache.org/user-forum.html

-Brian

On Mon, Jun 25, 2012 at 2:31 AM, Jan Agermose // Conviator ApS <[hidden email]> wrote:

hi

 

Im trying my way around activemq and stomp for PHP connectivity. Its a clean, fresh install - I only enabled stomp/nio and thats it. Then I created a producer and two consumers both sending ID (different) and then running it all.

 

the producer is sending OK but the strange thing is that the consumers are only getting every 2. msg.

 

If the producer is sending to /topic/test msg.:

 

test1

test2

test3

test4

 

then the first consumer is getting test1 and test3 and the 2. is getting test2 and test4

 

I would think thats a queue and using a topic both constumers shoudl get all 4 msg? Is this not the expected behavior? Or does this not work with stomp (the client is 1.0 it seams activemq is 5.6) or do I still need some configuration on the MQ to make it work?

 

thanks and best regards
Jan

 

 


Reply | Threaded
Open this post in threaded view
|

RE: basic setup, topic with more subscribers

jana

Hi

 

Thanks, yes. I actually did already and found that there is a problem with the current implementation of activemq5.6 in connection with the php stomp implementation. Its supposed to be fixed already both in the php stomp snapshot and 5.7 snapshot of activemq - I downloaded the 5.7 snapshot and its working now.

 

it should probably be on the stomp webpage since 1.0 of stomp and 5.6 are the current stable downloads listed and they dont work together.

 

From: Brian McCallister [mailto:[hidden email]]
Sent: 26. juni 2012 20:32
To: [hidden email]
Subject: Re: [stomp-user] basic setup, topic with more subscribers

 

Your best bet is probably to ask on the activemq mailing list http://activemq.apache.org/user-forum.html

 

-Brian

On Mon, Jun 25, 2012 at 2:31 AM, Jan Agermose // Conviator ApS <[hidden email]> wrote:

hi

 

Im trying my way around activemq and stomp for PHP connectivity. Its a clean, fresh install - I only enabled stomp/nio and thats it. Then I created a producer and two consumers both sending ID (different) and then running it all.

 

the producer is sending OK but the strange thing is that the consumers are only getting every 2. msg.

 

If the producer is sending to /topic/test msg.:

 

test1

test2

test3

test4

 

then the first consumer is getting test1 and test3 and the 2. is getting test2 and test4

 

I would think thats a queue and using a topic both constumers shoudl get all 4 msg? Is this not the expected behavior? Or does this not work with stomp (the client is 1.0 it seams activemq is 5.6) or do I still need some configuration on the MQ to make it work?

 

thanks and best regards
Jan