[activemq-user] Transacted session not working properly

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[activemq-user] Transacted session not working properly

Deepak Nayal
Hi

I am using transacted sessions for the JMS receiver. I am using the same
program as the sender and the receiver. First I run the program and
execute the sender part then I run the receiver part(this I do by
commenting the unrequired part). The receiver receives 10 messages in
total and commits after receiving 5; rest I rollback. The message
listener keeps on listening to the messages until I close the session
manually. Now, ideally the program should keep receiving the uncommited
messages endlessly because they are not committed. This behavior works
fine in weblogic server 8.1 and the receiver gets the JMS messages
endlessly. However, in ActiveMQ the uncommited messages are received
only once. and the program hangs.

This issues has already been discussed in this thread earlier but the
solution was not confirmed by the ActiveMQ team. Can anyone please let
me know if this is a bug?

There is another behavior that I witnessed. After leaving a couple of
messages uncommited even when I commit the rest of the messages in the
next runs of the client program the messages do not get removed from the
queue and the receiver keeps on receiving the messages everytime the run
the client.

I am attaching the client to this message. I am sure there isn't any
problem with the program as it works fine with weblogic server and this
sure does seem to be like a bug with Active MQ. BTW I am using ActiveMQ 3.0.

Regards
Deepak Nayal

ActiveMQJMSTest.java (3K) Download Attachment