[activemq-dev] Maven fail to get activemq-core-test-3.0.jar

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[activemq-dev] Maven fail to get activemq-core-test-3.0.jar

Scott Lewis-2
Hi,

I'm trying to build activemq and when running maven (from any number of
locations...e.g modules or top level) I get:

Attempting to download activemq-core-test-3.0.jar.
WARNING: Failed to download activemq-core-test-3.0.jar.

Any idea about why this is not working?  I've cleared maven cache and still same
thing.

Thanksinadvance,

Scott


Reply | Threaded
Open this post in threaded view
|

Re: [activemq-dev] Maven fail to get activemq-core-test-3.0.jar

chirino

That module only gets built by the modules/core project when the test  
cases are not skipped.  We may need to reorganize things around that  
problem.  It's due to the fact that we want the optional modules can  
re-use the base test classes in the core module in their test cases.  
But we don't want to include them in the core module.  What we are  
doing might not be the best mavenized way to do what this.  Anybody  
have any ideas of how to make this better but keep it simple?

Regards,
Hiram

On Jul 13, 2005, at 2:36 AM, Scott Lewis wrote:

> Hi,
>
> I'm trying to build activemq and when running maven (from any  
> number of
> locations...e.g modules or top level) I get:
>
> Attempting to download activemq-core-test-3.0.jar.
> WARNING: Failed to download activemq-core-test-3.0.jar.
>
> Any idea about why this is not working?  I've cleared maven cache  
> and still same
> thing.
>
> Thanksinadvance,
>
> Scott
>
>