activemq-cpp-3.9.4 fails to build fedora rawhide - openssl-1.1.0e related.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

activemq-cpp-3.9.4 fails to build fedora rawhide - openssl-1.1.0e related.

traylenator
Hi

Building activemq-cpp-3.9.4 results in a

decaf/internal/net/ssl/openssl/OpenSSLSocket.cpp:667:50: error: invalid use of incomplete type 'X509_EXTENSION {aka struct X509_extension_st}'
             const unsigned char* data = extension->value->data;
                                                  ^~
In file included from /usr/include/openssl/ssl.h:50:0,
                 from decaf/internal/net/ssl/openssl/OpenSSLSocket.cpp:21:
/usr/include/openssl/x509.h:79:16: note: forward declaration of 'X509_EXTENSION {aka struct X509_extension_st}'
 typedef struct X509_extension_st X509_EXTENSION;
                ^~~~~~~~~~~~~~~~~
decaf/internal/net/ssl/openssl/OpenSSLSocket.cpp:667:52: error: invalid use of incomplete type 'X509_EXTENSION {aka struct X509_extension_st}'
             const unsigned char* data = extension->value->data;
                                                    ^~~~~
In file included from /usr/include/openssl/ssl.h:50:0,
                 from decaf/internal/net/ssl/openssl/OpenSSLSocket.cpp:21:
/usr/include/openssl/x509.h:79:16: note: forward declaration of 'X509_EXTENSION {aka struct X509_extension_st}'
 typedef struct X509_extension_st X509_EXTENSION;
                ^~~~~~~~~~~~~~~~~
decaf/internal/net/ssl/openssl/OpenSSLSocket.cpp:670:65: error: invalid use of incomplete type 'X509_EXTENSION {aka struct X509_extension_st}'
                             ASN1_item_d2i(NULL, &data, extension->value->length, ASN1_ITEM_ptr(method->it)) :


I expect it's something required for openssl 1.1.0e

Full logs of what was installed (root.log) and the build logs (build.log) are attached.

root.logbuild.log.






Reply | Threaded
Open this post in threaded view
|

Re: activemq-cpp-3.9.4 fails to build fedora rawhide - openssl-1.1.0e related.

traylenator
Reply | Threaded
Open this post in threaded view
|

Re: activemq-cpp-3.9.4 fails to build fedora rawhide - openssl-1.1.0e related.

baklan120
You should replace extension->value->data with the ASN1_STRING_data(X509_EXTENSION_get_data(extension)) and extension->value->length (twice) with the ASN1_STRING_length(X509_EXTENSION_get_data(extension))).

traylenator wrote

decaf/internal/net/ssl/openssl/OpenSSLSocket.cpp:667:50: error: invalid use of incomplete type 'X509_EXTENSION {aka struct X509_extension_st}'
             const unsigned char* data = extension->value->data;
                                                  ^~
In file included from /usr/include/openssl/ssl.h:50:0,
                 from decaf/internal/net/ssl/openssl/OpenSSLSocket.cpp:21:
/usr/include/openssl/x509.h:79:16: note: forward declaration of 'X509_EXTENSION {aka struct X509_extension_st}'
 typedef struct X509_extension_st X509_EXTENSION;
                ^~~~~~~~~~~~~~~~~
decaf/internal/net/ssl/openssl/OpenSSLSocket.cpp:667:52: error: invalid use of incomplete type 'X509_EXTENSION {aka struct X509_extension_st}'
             const unsigned char* data = extension->value->data;
                                                    ^~~~~
In file included from /usr/include/openssl/ssl.h:50:0,
                 from decaf/internal/net/ssl/openssl/OpenSSLSocket.cpp:21:
/usr/include/openssl/x509.h:79:16: note: forward declaration of 'X509_EXTENSION {aka struct X509_extension_st}'
 typedef struct X509_extension_st X509_EXTENSION;
                ^~~~~~~~~~~~~~~~~
decaf/internal/net/ssl/openssl/OpenSSLSocket.cpp:670:65: error: invalid use of incomplete type 'X509_EXTENSION {aka struct X509_extension_st}'
                             ASN1_item_d2i(NULL, &data, extension->value->length, ASN1_ITEM_ptr(method->it)) :
Reply | Threaded
Open this post in threaded view
|

Re: activemq-cpp-3.9.4 fails to build fedora rawhide - openssl-1.1.0e related.

acpmasquerade
Checking in just to confirm that same issue was encountered while building on
Ubuntu 16.04 and openssl 1.0.2

Fixed by replacing as suggested above.

PS: What is the datatype of extension->value->length ?



--
Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html