[VOTE] Apache ActiveMQ 5.15.10 release (take #3)

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[VOTE] Apache ActiveMQ 5.15.10 release (take #3)

jbonofre
Hi guys,

I'm submitting ActiveMQ 5.15.10 release to your vote.

This release includes dependency updates, and improvements.

Please take a look on the Release Notes for details:

https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311210&version=12345171

The Maven staging repository is:
https://repository.apache.org/content/repositories/orgapacheactivemq-1195

The dist staging repository is:
https://dist.apache.org/repos/dist/dev/activemq/activemq/5.15.10/

Git tag:
activemq-5.15.10

Please vote to approve this release:

[ ] +1 Approve the release
[ ] -1 Don't approve the release (please provide specific comments)

This vote will be open for at least 72 hours.

Thanks !
Regards
JB
--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Apache ActiveMQ 5.15.10 release (take #3)

Colm O hEigeartaigh
When I try to log on to the web console there is an error in the logs:

javax.servlet.ServletException: javax.servlet.ServletException:
org.apache.jasper.JasperException: java.lang.IllegalStateException: No Java
compiler available for configuration options compilerClassName: [null] and
compiler: [null]
    at
org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:168)[jetty-all-9.4.19.v20190610-uber.jar:9.4.19.v20190610]

Colm.

On Mon, Aug 26, 2019 at 9:00 PM Jean-Baptiste Onofré <[hidden email]>
wrote:

> Hi guys,
>
> I'm submitting ActiveMQ 5.15.10 release to your vote.
>
> This release includes dependency updates, and improvements.
>
> Please take a look on the Release Notes for details:
>
>
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311210&version=12345171
>
> The Maven staging repository is:
> https://repository.apache.org/content/repositories/orgapacheactivemq-1195
>
> The dist staging repository is:
> https://dist.apache.org/repos/dist/dev/activemq/activemq/5.15.10/
>
> Git tag:
> activemq-5.15.10
>
> Please vote to approve this release:
>
> [ ] +1 Approve the release
> [ ] -1 Don't approve the release (please provide specific comments)
>
> This vote will be open for at least 72 hours.
>
> Thanks !
> Regards
> JB
> --
> Jean-Baptiste Onofré
> [hidden email]
> http://blog.nanthrax.net
> Talend - http://www.talend.com
>
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Apache ActiveMQ 5.15.10 release (take #3)

Colm O hEigeartaigh
The cause is a missing ecj jar. I'm preparing a PR now.

Colm.

On Tue, Aug 27, 2019 at 10:12 AM Colm O hEigeartaigh <[hidden email]>
wrote:

> When I try to log on to the web console there is an error in the logs:
>
> javax.servlet.ServletException: javax.servlet.ServletException:
> org.apache.jasper.JasperException: java.lang.IllegalStateException: No Java
> compiler available for configuration options compilerClassName: [null] and
> compiler: [null]
>     at
> org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:168)[jetty-all-9.4.19.v20190610-uber.jar:9.4.19.v20190610]
>
> Colm.
>
> On Mon, Aug 26, 2019 at 9:00 PM Jean-Baptiste Onofré <[hidden email]>
> wrote:
>
>> Hi guys,
>>
>> I'm submitting ActiveMQ 5.15.10 release to your vote.
>>
>> This release includes dependency updates, and improvements.
>>
>> Please take a look on the Release Notes for details:
>>
>>
>> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311210&version=12345171
>>
>> The Maven staging repository is:
>> https://repository.apache.org/content/repositories/orgapacheactivemq-1195
>>
>> The dist staging repository is:
>> https://dist.apache.org/repos/dist/dev/activemq/activemq/5.15.10/
>>
>> Git tag:
>> activemq-5.15.10
>>
>> Please vote to approve this release:
>>
>> [ ] +1 Approve the release
>> [ ] -1 Don't approve the release (please provide specific comments)
>>
>> This vote will be open for at least 72 hours.
>>
>> Thanks !
>> Regards
>> JB
>> --
>> Jean-Baptiste Onofré
>> [hidden email]
>> http://blog.nanthrax.net
>> Talend - http://www.talend.com
>>
>
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Apache ActiveMQ 5.15.10 release (take #3)

christopher.l.shannon
I noticed the same thing with the webconsole and was about to -1 for that.

If you update versions of Jetty you need to really test out all parts that
use it...unit tests, websockets, HTTP transport, webconsole, TLS support,
etc as a lot of things seemed to be changed between Jetty versions that are
breaking changes with config and jars.

On Tue, Aug 27, 2019 at 5:33 AM Colm O hEigeartaigh <[hidden email]>
wrote:

> The cause is a missing ecj jar. I'm preparing a PR now.
>
> Colm.
>
> On Tue, Aug 27, 2019 at 10:12 AM Colm O hEigeartaigh <[hidden email]>
> wrote:
>
> > When I try to log on to the web console there is an error in the logs:
> >
> > javax.servlet.ServletException: javax.servlet.ServletException:
> > org.apache.jasper.JasperException: java.lang.IllegalStateException: No
> Java
> > compiler available for configuration options compilerClassName: [null]
> and
> > compiler: [null]
> >     at
> >
> org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:168)[jetty-all-9.4.19.v20190610-uber.jar:9.4.19.v20190610]
> >
> > Colm.
> >
> > On Mon, Aug 26, 2019 at 9:00 PM Jean-Baptiste Onofré <[hidden email]>
> > wrote:
> >
> >> Hi guys,
> >>
> >> I'm submitting ActiveMQ 5.15.10 release to your vote.
> >>
> >> This release includes dependency updates, and improvements.
> >>
> >> Please take a look on the Release Notes for details:
> >>
> >>
> >>
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311210&version=12345171
> >>
> >> The Maven staging repository is:
> >>
> https://repository.apache.org/content/repositories/orgapacheactivemq-1195
> >>
> >> The dist staging repository is:
> >> https://dist.apache.org/repos/dist/dev/activemq/activemq/5.15.10/
> >>
> >> Git tag:
> >> activemq-5.15.10
> >>
> >> Please vote to approve this release:
> >>
> >> [ ] +1 Approve the release
> >> [ ] -1 Don't approve the release (please provide specific comments)
> >>
> >> This vote will be open for at least 72 hours.
> >>
> >> Thanks !
> >> Regards
> >> JB
> >> --
> >> Jean-Baptiste Onofré
> >> [hidden email]
> >> http://blog.nanthrax.net
> >> Talend - http://www.talend.com
> >>
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Apache ActiveMQ 5.15.10 release (take #3)

Colm O hEigeartaigh
Here's a PR that fixes the problem:
https://github.com/apache/activemq/pull/391

Colm.

On Tue, Aug 27, 2019 at 11:51 AM Christopher Shannon <
[hidden email]> wrote:

> I noticed the same thing with the webconsole and was about to -1 for that.
>
> If you update versions of Jetty you need to really test out all parts that
> use it...unit tests, websockets, HTTP transport, webconsole, TLS support,
> etc as a lot of things seemed to be changed between Jetty versions that are
> breaking changes with config and jars.
>
> On Tue, Aug 27, 2019 at 5:33 AM Colm O hEigeartaigh <[hidden email]>
> wrote:
>
> > The cause is a missing ecj jar. I'm preparing a PR now.
> >
> > Colm.
> >
> > On Tue, Aug 27, 2019 at 10:12 AM Colm O hEigeartaigh <
> [hidden email]>
> > wrote:
> >
> > > When I try to log on to the web console there is an error in the logs:
> > >
> > > javax.servlet.ServletException: javax.servlet.ServletException:
> > > org.apache.jasper.JasperException: java.lang.IllegalStateException: No
> > Java
> > > compiler available for configuration options compilerClassName: [null]
> > and
> > > compiler: [null]
> > >     at
> > >
> >
> org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:168)[jetty-all-9.4.19.v20190610-uber.jar:9.4.19.v20190610]
> > >
> > > Colm.
> > >
> > > On Mon, Aug 26, 2019 at 9:00 PM Jean-Baptiste Onofré <[hidden email]>
> > > wrote:
> > >
> > >> Hi guys,
> > >>
> > >> I'm submitting ActiveMQ 5.15.10 release to your vote.
> > >>
> > >> This release includes dependency updates, and improvements.
> > >>
> > >> Please take a look on the Release Notes for details:
> > >>
> > >>
> > >>
> >
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311210&version=12345171
> > >>
> > >> The Maven staging repository is:
> > >>
> >
> https://repository.apache.org/content/repositories/orgapacheactivemq-1195
> > >>
> > >> The dist staging repository is:
> > >> https://dist.apache.org/repos/dist/dev/activemq/activemq/5.15.10/
> > >>
> > >> Git tag:
> > >> activemq-5.15.10
> > >>
> > >> Please vote to approve this release:
> > >>
> > >> [ ] +1 Approve the release
> > >> [ ] -1 Don't approve the release (please provide specific comments)
> > >>
> > >> This vote will be open for at least 72 hours.
> > >>
> > >> Thanks !
> > >> Regards
> > >> JB
> > >> --
> > >> Jean-Baptiste Onofré
> > >> [hidden email]
> > >> http://blog.nanthrax.net
> > >> Talend - http://www.talend.com
> > >>
> > >
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Apache ActiveMQ 5.15.10 release (take #3)

christopher.l.shannon
So actually the more I think about it, I don't know that we should even be
upgrading Jetty from 9.2.x to 9.4.x in a minor release.  That seems more
like a 5.16.0 thing.  That's a big Jetty upgrade and as we have seen might
cause a lot of issues with compatibility (especially people using an
embedded broker with transitive dependencies on Jetty)

On Tue, Aug 27, 2019 at 10:12 AM Colm O hEigeartaigh <[hidden email]>
wrote:

> Here's a PR that fixes the problem:
> https://github.com/apache/activemq/pull/391
>
> Colm.
>
> On Tue, Aug 27, 2019 at 11:51 AM Christopher Shannon <
> [hidden email]> wrote:
>
> > I noticed the same thing with the webconsole and was about to -1 for
> that.
> >
> > If you update versions of Jetty you need to really test out all parts
> that
> > use it...unit tests, websockets, HTTP transport, webconsole, TLS support,
> > etc as a lot of things seemed to be changed between Jetty versions that
> are
> > breaking changes with config and jars.
> >
> > On Tue, Aug 27, 2019 at 5:33 AM Colm O hEigeartaigh <[hidden email]
> >
> > wrote:
> >
> > > The cause is a missing ecj jar. I'm preparing a PR now.
> > >
> > > Colm.
> > >
> > > On Tue, Aug 27, 2019 at 10:12 AM Colm O hEigeartaigh <
> > [hidden email]>
> > > wrote:
> > >
> > > > When I try to log on to the web console there is an error in the
> logs:
> > > >
> > > > javax.servlet.ServletException: javax.servlet.ServletException:
> > > > org.apache.jasper.JasperException: java.lang.IllegalStateException:
> No
> > > Java
> > > > compiler available for configuration options compilerClassName:
> [null]
> > > and
> > > > compiler: [null]
> > > >     at
> > > >
> > >
> >
> org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:168)[jetty-all-9.4.19.v20190610-uber.jar:9.4.19.v20190610]
> > > >
> > > > Colm.
> > > >
> > > > On Mon, Aug 26, 2019 at 9:00 PM Jean-Baptiste Onofré <
> [hidden email]>
> > > > wrote:
> > > >
> > > >> Hi guys,
> > > >>
> > > >> I'm submitting ActiveMQ 5.15.10 release to your vote.
> > > >>
> > > >> This release includes dependency updates, and improvements.
> > > >>
> > > >> Please take a look on the Release Notes for details:
> > > >>
> > > >>
> > > >>
> > >
> >
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311210&version=12345171
> > > >>
> > > >> The Maven staging repository is:
> > > >>
> > >
> >
> https://repository.apache.org/content/repositories/orgapacheactivemq-1195
> > > >>
> > > >> The dist staging repository is:
> > > >> https://dist.apache.org/repos/dist/dev/activemq/activemq/5.15.10/
> > > >>
> > > >> Git tag:
> > > >> activemq-5.15.10
> > > >>
> > > >> Please vote to approve this release:
> > > >>
> > > >> [ ] +1 Approve the release
> > > >> [ ] -1 Don't approve the release (please provide specific comments)
> > > >>
> > > >> This vote will be open for at least 72 hours.
> > > >>
> > > >> Thanks !
> > > >> Regards
> > > >> JB
> > > >> --
> > > >> Jean-Baptiste Onofré
> > > >> [hidden email]
> > > >> http://blog.nanthrax.net
> > > >> Talend - http://www.talend.com
> > > >>
> > > >
> > >
> >
>
Reply | Threaded
Open this post in threaded view
|

[CANCEL][VOTE] Apache ActiveMQ 5.15.10 release (take #3)

jbonofre
In reply to this post by jbonofre
Hi,

due to identified AMQ-7292, I cancel this vote to fix it.

Sorry about that.

Regards
JB

On 26/08/2019 22:00, Jean-Baptiste Onofré wrote:

> Hi guys,
>
> I'm submitting ActiveMQ 5.15.10 release to your vote.
>
> This release includes dependency updates, and improvements.
>
> Please take a look on the Release Notes for details:
>
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311210&version=12345171
>
> The Maven staging repository is:
> https://repository.apache.org/content/repositories/orgapacheactivemq-1195
>
> The dist staging repository is:
> https://dist.apache.org/repos/dist/dev/activemq/activemq/5.15.10/
>
> Git tag:
> activemq-5.15.10
>
> Please vote to approve this release:
>
> [ ] +1 Approve the release
> [ ] -1 Don't approve the release (please provide specific comments)
>
> This vote will be open for at least 72 hours.
>
> Thanks !
> Regards
> JB
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com