Upgrading ActiveMQ core lib in Apache James 3.0

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Upgrading ActiveMQ core lib in Apache James 3.0

Adam Raszkiewicz
Hi all,

I’m trying to upgrade ActiveMQ core lib in Apache James 3.0 from 5.4.2 to 5.5.1 based on suggestions from that ticket:
https://issues.apache.org/jira/browse/JAMES-1394?focusedCommentId=13725197

but after restarting Apache James I’m getting that error:
[TID=18] WARN  13:46:58,628 | org.springframework.beans.factory.xml.XmlBeanDefinitionReader | Ignored XML validation warning
org.xml.sax.SAXParseException: schema_reference.4: Failed to read schema document 'classpath:activemq.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.

I thought it will pick up XML schema from previous version.

Any suggestions on that matter?

Thanks,
Adam