Upgrade Tanuki Service Wrapper for ActiveMQ 5.9.0?

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Upgrade Tanuki Service Wrapper for ActiveMQ 5.9.0?

paulgale
Hi,

Not sure if this has already happened or not, as I'm not using 5.9.0 yet,
but I was wondering if the Tanuki Service Wrapper that ships with ActiveMQ
is going to be upgraded as part of the 5.9.0 release?

The version that shipped with ActiveMQ 5.8.0 is very old.

I can create a JIRA for this issue if this works needs to happen. Let me
know.

Thanks,
Paul
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade Tanuki Service Wrapper for ActiveMQ 5.9.0?

jbonofre
Hi Paul,

Actually it's not so simple. Tanuki JSW 3.2.3 is the latest one under Apache license. After, they changed to GPL, which is a category X for Apache (so not usable in an Apache project).

For Karaf, I compiled the native lib for new architectures.

Regards
JB
--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://wwx.talend.com

----- Reply message -----
From: "Paul Gale" <[hidden email]>
To: <[hidden email]>
Subject: Upgrade Tanuki Service Wrapper for ActiveMQ 5.9.0?
Date: Mon, Sep 16, 2013 2:37 pm


Hi,

Not sure if this has already happened or not, as I'm not using 5.9.0 yet,
but I was wondering if the Tanuki Service Wrapper that ships with ActiveMQ
is going to be upgraded as part of the 5.9.0 release?

The version that shipped with ActiveMQ 5.8.0 is very old.

I can create a JIRA for this issue if this works needs to happen. Let me
know.

Thanks,
Paul
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade Tanuki Service Wrapper for ActiveMQ 5.9.0?

Claus Ibsen
In reply to this post by paulgale
Hi

AFAIK this is not possible to upgrade as Tankui changed licensing so
the newer versions requires you to buy a license to use it. The old
version that is shipped with ActiveMQ is still allowed to use for free
without paying. Therefore we need to stick to  that version.

This has been debated before so you can possible find old mail threads
about this.

On Mon, Sep 16, 2013 at 3:37 PM, Paul Gale <[hidden email]> wrote:

> Hi,
>
> Not sure if this has already happened or not, as I'm not using 5.9.0 yet,
> but I was wondering if the Tanuki Service Wrapper that ships with ActiveMQ
> is going to be upgraded as part of the 5.9.0 release?
>
> The version that shipped with ActiveMQ 5.8.0 is very old.
>
> I can create a JIRA for this issue if this works needs to happen. Let me
> know.
>
> Thanks,
> Paul



--
Claus Ibsen
-----------------
Red Hat, Inc.
Email: [hidden email]
Twitter: davsclaus
Blog: http://davsclaus.com
Author of Camel in Action: http://www.manning.com/ibsen
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade Tanuki Service Wrapper for ActiveMQ 5.9.0?

tabish121@gmail.com
In reply to this post by paulgale
On 09/16/2013 09:37 AM, Paul Gale wrote:

> Hi,
>
> Not sure if this has already happened or not, as I'm not using 5.9.0 yet,
> but I was wondering if the Tanuki Service Wrapper that ships with ActiveMQ
> is going to be upgraded as part of the 5.9.0 release?
>
> The version that shipped with ActiveMQ 5.8.0 is very old.
>
> I can create a JIRA for this issue if this works needs to happen. Let me
> know.
>
> Thanks,
> Paul
>
 From what I know right now the version we use is the latest one we can
get our hands on before they went closed and required a license so I
don't think there's anything we can move to besides what's already there.

--
Tim Bish
Sr Software Engineer | RedHat Inc.
[hidden email] | www.fusesource.com | www.redhat.com
skype: tabish121 | twitter: @tabish121
blog: http://timbish.blogspot.com/

Reply | Threaded
Open this post in threaded view
|

Re: Upgrade Tanuki Service Wrapper for ActiveMQ 5.9.0?

paulgale
In reply to this post by Claus Ibsen
>AFAIK this is not possible to upgrade as Tankui changed licensing so the
newer versions requires you to buy a license to use it.

FYI: the 'community edition' is free. Shame about the GPL/Apache conflict
though.

"Community License Agreement: This license agreement is based on the
popular GPL v2 (General Public License ver.2) license used by many open
source projects. For open source projects, this is a good choice as it
allows the Wrapper to be redistributed as part of any application provided
that all source of the application is made available to the user base free
of charge."

For our purposed we can upgrade to the latest JSW in our locally deployed
version of ActiveMQ.




On Mon, Sep 16, 2013 at 9:49 AM, Claus Ibsen <[hidden email]> wrote:

> Hi
>
> AFAIK this is not possible to upgrade as Tankui changed licensing so
> the newer versions requires you to buy a license to use it. The old
> version that is shipped with ActiveMQ is still allowed to use for free
> without paying. Therefore we need to stick to  that version.
>
> This has been debated before so you can possible find old mail threads
> about this.
>
> On Mon, Sep 16, 2013 at 3:37 PM, Paul Gale <[hidden email]> wrote:
> > Hi,
> >
> > Not sure if this has already happened or not, as I'm not using 5.9.0 yet,
> > but I was wondering if the Tanuki Service Wrapper that ships with
> ActiveMQ
> > is going to be upgraded as part of the 5.9.0 release?
> >
> > The version that shipped with ActiveMQ 5.8.0 is very old.
> >
> > I can create a JIRA for this issue if this works needs to happen. Let me
> > know.
> >
> > Thanks,
> > Paul
>
>
>
> --
> Claus Ibsen
> -----------------
> Red Hat, Inc.
> Email: [hidden email]
> Twitter: davsclaus
> Blog: http://davsclaus.com
> Author of Camel in Action: http://www.manning.com/ibsen
>
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade Tanuki Service Wrapper for ActiveMQ 5.9.0?

paulgale
In reply to this post by jbonofre
>For Karaf, I compiled the native lib for new architectures.

I don't understand. What 'native lib' are you referring to and how does
that help? Just wondering, as I'm ignorant of these things.


On Mon, Sep 16, 2013 at 9:48 AM, [hidden email] <[hidden email]> wrote:

> Hi Paul,
>
> Actually it's not so simple. Tanuki JSW 3.2.3 is the latest one under
> Apache license. After, they changed to GPL, which is a category X for
> Apache (so not usable in an Apache project).
>
> For Karaf, I compiled the native lib for new architectures.
>
> Regards
> JB
> --
> Jean-Baptiste Onofré
> [hidden email]
> http://blog.nanthrax.net
> Talend - http://wwx.talend.com
>
> ----- Reply message -----
> From: "Paul Gale" <[hidden email]>
> To: <[hidden email]>
> Subject: Upgrade Tanuki Service Wrapper for ActiveMQ 5.9.0?
> Date: Mon, Sep 16, 2013 2:37 pm
>
>
> Hi,
>
> Not sure if this has already happened or not, as I'm not using 5.9.0 yet,
> but I was wondering if the Tanuki Service Wrapper that ships with ActiveMQ
> is going to be upgraded as part of the 5.9.0 release?
>
> The version that shipped with ActiveMQ 5.8.0 is very old.
>
> I can create a JIRA for this issue if this works needs to happen. Let me
> know.
>
> Thanks,
> Paul
>
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade Tanuki Service Wrapper for ActiveMQ 5.9.0?

ceposta
This has come up before.

Paul, open a JIRA to look at using
https://kenai.com/projects/winsw/downloads for ActiveMQ


On Mon, Sep 16, 2013 at 7:02 AM, Paul Gale <[hidden email]> wrote:

> >For Karaf, I compiled the native lib for new architectures.
>
> I don't understand. What 'native lib' are you referring to and how does
> that help? Just wondering, as I'm ignorant of these things.
>
>
> On Mon, Sep 16, 2013 at 9:48 AM, [hidden email] <[hidden email]> wrote:
>
> > Hi Paul,
> >
> > Actually it's not so simple. Tanuki JSW 3.2.3 is the latest one under
> > Apache license. After, they changed to GPL, which is a category X for
> > Apache (so not usable in an Apache project).
> >
> > For Karaf, I compiled the native lib for new architectures.
> >
> > Regards
> > JB
> > --
> > Jean-Baptiste Onofré
> > [hidden email]
> > http://blog.nanthrax.net
> > Talend - http://wwx.talend.com
> >
> > ----- Reply message -----
> > From: "Paul Gale" <[hidden email]>
> > To: <[hidden email]>
> > Subject: Upgrade Tanuki Service Wrapper for ActiveMQ 5.9.0?
> > Date: Mon, Sep 16, 2013 2:37 pm
> >
> >
> > Hi,
> >
> > Not sure if this has already happened or not, as I'm not using 5.9.0 yet,
> > but I was wondering if the Tanuki Service Wrapper that ships with
> ActiveMQ
> > is going to be upgraded as part of the 5.9.0 release?
> >
> > The version that shipped with ActiveMQ 5.8.0 is very old.
> >
> > I can create a JIRA for this issue if this works needs to happen. Let me
> > know.
> >
> > Thanks,
> > Paul
> >
>



--
*Christian Posta*
http://www.christianposta.com/blog
twitter: @christianposta
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade Tanuki Service Wrapper for ActiveMQ 5.9.0?

paulgale
This is a Windows based project which doesn't help me as I'm on RHEL.


On Mon, Sep 16, 2013 at 10:33 AM, Christian Posta <[hidden email]
> wrote:

> This has come up before.
>
> Paul, open a JIRA to look at using
> https://kenai.com/projects/winsw/downloads for ActiveMQ
>
>
> On Mon, Sep 16, 2013 at 7:02 AM, Paul Gale <[hidden email]> wrote:
>
> > >For Karaf, I compiled the native lib for new architectures.
> >
> > I don't understand. What 'native lib' are you referring to and how does
> > that help? Just wondering, as I'm ignorant of these things.
> >
> >
> > On Mon, Sep 16, 2013 at 9:48 AM, [hidden email] <[hidden email]>
> wrote:
> >
> > > Hi Paul,
> > >
> > > Actually it's not so simple. Tanuki JSW 3.2.3 is the latest one under
> > > Apache license. After, they changed to GPL, which is a category X for
> > > Apache (so not usable in an Apache project).
> > >
> > > For Karaf, I compiled the native lib for new architectures.
> > >
> > > Regards
> > > JB
> > > --
> > > Jean-Baptiste Onofré
> > > [hidden email]
> > > http://blog.nanthrax.net
> > > Talend - http://wwx.talend.com
> > >
> > > ----- Reply message -----
> > > From: "Paul Gale" <[hidden email]>
> > > To: <[hidden email]>
> > > Subject: Upgrade Tanuki Service Wrapper for ActiveMQ 5.9.0?
> > > Date: Mon, Sep 16, 2013 2:37 pm
> > >
> > >
> > > Hi,
> > >
> > > Not sure if this has already happened or not, as I'm not using 5.9.0
> yet,
> > > but I was wondering if the Tanuki Service Wrapper that ships with
> > ActiveMQ
> > > is going to be upgraded as part of the 5.9.0 release?
> > >
> > > The version that shipped with ActiveMQ 5.8.0 is very old.
> > >
> > > I can create a JIRA for this issue if this works needs to happen. Let
> me
> > > know.
> > >
> > > Thanks,
> > > Paul
> > >
> >
>
>
>
> --
> *Christian Posta*
> http://www.christianposta.com/blog
> twitter: @christianposta
>
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade Tanuki Service Wrapper for ActiveMQ 5.9.0?

jbonofre
In reply to this post by paulgale
Hi Paul,

Tanuki JSW is composed into part:
- the Java service wrapper itself (written in Java)
- the native lib (so, dll) call by the Java service wrapper. This lib is
responsible of starting/stopping the JVM, trapping signals, etc

JSW 3.2.3 (which is old) also provided 32 bits binary version of the
native lib, and not native lib for all system (for instance Windows 7 or
8 were not supported because they didn't exist at the time of JSW 3.2.3).

So, I recompiled the native lib for 64 bits system (Solaris Sparc64,
Linux 64 bits, ...) and Windows 7/8 platforms.

Regards
JB

On 09/16/2013 04:02 PM, Paul Gale wrote:

>> For Karaf, I compiled the native lib for new architectures.
>
> I don't understand. What 'native lib' are you referring to and how does
> that help? Just wondering, as I'm ignorant of these things.
>
>
> On Mon, Sep 16, 2013 at 9:48 AM, [hidden email] <[hidden email]> wrote:
>
>> Hi Paul,
>>
>> Actually it's not so simple. Tanuki JSW 3.2.3 is the latest one under
>> Apache license. After, they changed to GPL, which is a category X for
>> Apache (so not usable in an Apache project).
>>
>> For Karaf, I compiled the native lib for new architectures.
>>
>> Regards
>> JB
>> --
>> Jean-Baptiste Onofré
>> [hidden email]
>> http://blog.nanthrax.net
>> Talend - http://wwx.talend.com
>>
>> ----- Reply message -----
>> From: "Paul Gale" <[hidden email]>
>> To: <[hidden email]>
>> Subject: Upgrade Tanuki Service Wrapper for ActiveMQ 5.9.0?
>> Date: Mon, Sep 16, 2013 2:37 pm
>>
>>
>> Hi,
>>
>> Not sure if this has already happened or not, as I'm not using 5.9.0 yet,
>> but I was wondering if the Tanuki Service Wrapper that ships with ActiveMQ
>> is going to be upgraded as part of the 5.9.0 release?
>>
>> The version that shipped with ActiveMQ 5.8.0 is very old.
>>
>> I can create a JIRA for this issue if this works needs to happen. Let me
>> know.
>>
>> Thanks,
>> Paul
>>
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com