Unresolved constraint in bundle activemq-karaf when trying to upgrade to AMQ 5.13.2

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Unresolved constraint in bundle activemq-karaf when trying to upgrade to AMQ 5.13.2

Martin Lichtin
I see

org.osgi.framework.BundleException: Unresolved constraint in bundle activemq-karaf [124]: Unable to resolve 124.0: missing requirement [124.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.16.0)(!(version>=1.0.0)))

when trying to upgrade ActiveMQ from 5.12.2 to 5.13.2, running in Karaf 3.0.3.

Does the latest ActiveMQ require certain minimal Karaf versions?

Reply | Threaded
Open this post in threaded view
|

Re: Unresolved constraint in bundle activemq-karaf when trying to upgrade to AMQ 5.13.2

christopher.l.shannon
5.13.0 was updated to Karaf 4 because of pax web and the upgrade to Jetty
9.2.x.

On Fri, Apr 1, 2016 at 11:48 AM, Martin Lichtin <[hidden email]>
wrote:

> I see
>
> org.osgi.framework.BundleException: Unresolved constraint in bundle
> activemq-karaf [124]: Unable to resolve 124.0: missing requirement [124.0]
> osgi.wiring.package;
> (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.16.0)(!(version>=1.0.0)))
>
> when trying to upgrade ActiveMQ from 5.12.2 to 5.13.2, running in Karaf
> 3.0.3.
>
> Does the latest ActiveMQ require certain minimal Karaf versions?
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Unresolved constraint in bundle activemq-karaf when trying to upgrade to AMQ 5.13.2

lichtin
Understood.
I am suggesting an improvement https://issues.apache.org/jira/browse/AMQ-6407
as it should still be possible to use ActiveMQ with Karaf 3.x.

christopher.l.shannon wrote
5.13.0 was updated to Karaf 4 because of pax web and the upgrade to Jetty
9.2.x.

On Fri, Apr 1, 2016 at 11:48 AM, Martin Lichtin <[hidden email]>
wrote:

> I see
>
> org.osgi.framework.BundleException: Unresolved constraint in bundle
> activemq-karaf [124]: Unable to resolve 124.0: missing requirement [124.0]
> osgi.wiring.package;
> (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.16.0)(!(version>=1.0.0)))
>
> when trying to upgrade ActiveMQ from 5.12.2 to 5.13.2, running in Karaf
> 3.0.3.
>
> Does the latest ActiveMQ require certain minimal Karaf versions?
>
>