Struggling to set up core bridge between two clusters in ArtemisMQ (EAP 7.1)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Struggling to set up core bridge between two clusters in ArtemisMQ (EAP 7.1)

michael@inception.software
Trying to set up two message clusters, each with two members and a core
bridge between them.

Environment:  JBoss EAP 7.1 ArtemisMQ

Background:  Producers (web app) local to one messaging cluster write
messages to a queue.  Core bridge forwards messages to second cluster where
MDBs process requests.

Issues:
- No way to confirm cluster members are connecting as expected
- Not sure that the two clusters are configured separately and correctly
- Core bridge is not forwarding messages with no errors in the log

I suspect the two clusters can't see each other so I have my
broadcast-groups, discovery-groups, and cluster-connections misconfigured
somehow.  Have it working with static lists but not ideal due to p2p nature
of static lists and the scale of our environment.

Thanks,
Michael



--
Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html
Reply | Threaded
Open this post in threaded view
|

Re: Struggling to set up core bridge between two clusters in ArtemisMQ (EAP 7.1)

jbertram
> No way to confirm cluster members are connecting as expected

When cluster members connect to each other there should be a message logged
about the bridge that is formed between them. Aside from that, you can use
the listNetworkTopoloy management operation (I think that's exposed by EAP,
but not quite sure) to look at the cluster topology information.


> Not sure that the two clusters are configured separately and correctly.

Separate clusters on the same network should use an independent multicast
address and/or port.


> Core bridge is not forwarding messages with no errors in the log

Maybe turn on DEBUG logging and look for some clues there.  You haven't
provided any configuration information so it's hard to comment on this
one.  It may be a configuration issue or it may be environmental.  It's
impossible to say at this point.


Justin

On Thu, Jan 3, 2019 at 11:06 AM [hidden email]
<[hidden email]> wrote:

> Trying to set up two message clusters, each with two members and a core
> bridge between them.
>
> Environment:  JBoss EAP 7.1 ArtemisMQ
>
> Background:  Producers (web app) local to one messaging cluster write
> messages to a queue.  Core bridge forwards messages to second cluster where
> MDBs process requests.
>
> Issues:
> - No way to confirm cluster members are connecting as expected
> - Not sure that the two clusters are configured separately and correctly
> - Core bridge is not forwarding messages with no errors in the log
>
> I suspect the two clusters can't see each other so I have my
> broadcast-groups, discovery-groups, and cluster-connections misconfigured
> somehow.  Have it working with static lists but not ideal due to p2p nature
> of static lists and the scale of our environment.
>
> Thanks,
> Michael
>
>
>
> --
> Sent from:
> http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html
>