Re: [activemq-user] Re: Missing messages, failed to checkpoint and "null message" warnings

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: [activemq-user] Re: Missing messages, failed to checkpoint and "null message" warnings

chirino
Hi Matthew,

The problem should now be fixed in our latest 3.1-SNAPSHOT:
http://dist.codehaus.org/activemq/distributions/activemq-3.1- 
SNAPSHOT.zip
http://dist.codehaus.org/activemq/distributions/activemq-3.1- 
SNAPSHOT.tar.gz

Could you confirm that this fixes the problem with the journal for you?

Regards,
Hiram

On Jun 6, 2005, at 11:35 AM, Hiram Chirino wrote:

> Hi Matt,
>
> Since Fritz was able to reproduce the problem, It should not take  
> us long to fix it.  Looking into it now.
>
>
> On Jun 6, 2005, at 10:54 AM, Matthew Sinclair-Day wrote:
>
>
>> I re-ran some tests with the journal removed, using only derby,  
>> and the problem goes away.  The exceptions about not being able to  
>> checkpoint the database still occur.  Of course performance  
>> suffers greatly, and perhaps this changes
>>
>
> BTW it's odd you get checkpointing messages since the only  
> component that does checkpointing in ActiveMQ is the Journal.  Are  
> you sure you disabled it?
>
>
>
>> the timing enough in the system that the problem does not manifest.
>>
>> I also forgot to mention that the tests used transactions to  
>> consume messages.  The consumer was consuming 1000 messages before  
>> committing them.
>>
>> Matt Sinclair
>>
>>
>
> Regards,
> Hiram
>
>
>>
>