[PROPOSAL] Release ActiveMQ 5.15.9 ?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[PROPOSAL] Release ActiveMQ 5.15.9 ?

Jean-Baptiste Onofré
Hi guys,

For ActiveMQ 5.15.7, I did a change the ActiveMQ Karaf features XML to
simplify the installation of ActiveMQ in Karaf (especially for Karaf 4.2.x).

Unfortunately, this change is causing issue for Karaf 4.0.x & 4.1.x users.

I'm working on a fix right now
(https://issues.apache.org/jira/browse/AMQ-7076).

I would like to know if you would agree if I quickly do a ActiveMQ
5.15.9 release to include this fix, in order to limit the impact of the
users.

Thoughts ?

Thanks and sorry about that :/

Regards
JB
--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com
Reply | Threaded
Open this post in threaded view
|

Re: [PROPOSAL] Release ActiveMQ 5.15.9 ?

christopher.l.shannon
I would say in this case a user could just downgrade to 5.15.6 so I don't
know that this is a truly critical fix we need to rush out super fast.
Other fixes we have rushed out were because of possible data store
corruption, etc.

That being said we can still do another release relatively soon but in my
opinion I think we are hitting a point now where we are rushing out too
many releases too fast.  I'm all for having more releases but we should
still have at least some reasonable amount of time before releases go out
unless something really is critical and will cause permanent damage like
corrupting a store.

Before releasing 5.15.9 I would rather give 5.15.8 a couple weeks for
people to test out and report any bugs so we aren't quickly turning around
and having to do a 5.15.10 and 5.15.11 etc and allow more changes to go
into a 5.15.9.


On Thu, Nov 22, 2018 at 3:16 AM Jean-Baptiste Onofré <[hidden email]>
wrote:

> Hi guys,
>
> For ActiveMQ 5.15.7, I did a change the ActiveMQ Karaf features XML to
> simplify the installation of ActiveMQ in Karaf (especially for Karaf
> 4.2.x).
>
> Unfortunately, this change is causing issue for Karaf 4.0.x & 4.1.x users.
>
> I'm working on a fix right now
> (https://issues.apache.org/jira/browse/AMQ-7076).
>
> I would like to know if you would agree if I quickly do a ActiveMQ
> 5.15.9 release to include this fix, in order to limit the impact of the
> users.
>
> Thoughts ?
>
> Thanks and sorry about that :/
>
> Regards
> JB
> --
> Jean-Baptiste Onofré
> [hidden email]
> http://blog.nanthrax.net
> Talend - http://www.talend.com
>
Reply | Threaded
Open this post in threaded view
|

Re: [PROPOSAL] Release ActiveMQ 5.15.9 ?

Jean-Baptiste Onofré
Hi Christopher,

I don't ask for a release now, but relatively soon.

So, roughly a month before 5.15.9 is fine for me.

I think Karaf users can live with ActiveMQ 5.15.6 for now.

By the way, I tested the fix on Karaf 4.1.x and 4.2.x, both with
ActiveMQ 5.16.0-SNAPSHOT (master) and 5.15.9-SNAPSHOT (activemq-5.15.x).
So I will merge the PRs.

Thanks !
Regards
JB

On 22/11/2018 10:30, Christopher Shannon wrote:

> I would say in this case a user could just downgrade to 5.15.6 so I don't
> know that this is a truly critical fix we need to rush out super fast.
> Other fixes we have rushed out were because of possible data store
> corruption, etc.
>
> That being said we can still do another release relatively soon but in my
> opinion I think we are hitting a point now where we are rushing out too
> many releases too fast.  I'm all for having more releases but we should
> still have at least some reasonable amount of time before releases go out
> unless something really is critical and will cause permanent damage like
> corrupting a store.
>
> Before releasing 5.15.9 I would rather give 5.15.8 a couple weeks for
> people to test out and report any bugs so we aren't quickly turning around
> and having to do a 5.15.10 and 5.15.11 etc and allow more changes to go
> into a 5.15.9.
>
>
> On Thu, Nov 22, 2018 at 3:16 AM Jean-Baptiste Onofré <[hidden email]>
> wrote:
>
>> Hi guys,
>>
>> For ActiveMQ 5.15.7, I did a change the ActiveMQ Karaf features XML to
>> simplify the installation of ActiveMQ in Karaf (especially for Karaf
>> 4.2.x).
>>
>> Unfortunately, this change is causing issue for Karaf 4.0.x & 4.1.x users.
>>
>> I'm working on a fix right now
>> (https://issues.apache.org/jira/browse/AMQ-7076).
>>
>> I would like to know if you would agree if I quickly do a ActiveMQ
>> 5.15.9 release to include this fix, in order to limit the impact of the
>> users.
>>
>> Thoughts ?
>>
>> Thanks and sorry about that :/
>>
>> Regards
>> JB
>> --
>> Jean-Baptiste Onofré
>> [hidden email]
>> http://blog.nanthrax.net
>> Talend - http://www.talend.com
>>
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com