Mysql 5.6 and activemq

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Mysql 5.6 and activemq

rookie
This post has NOT been accepted by the mailing list yet.
We migrated from mySQL server 5.5 to 5.6 and i get the following exception during my mq initilization piece  in the project

Caused by: java.io.IOException: Failed to get Message Count: queue://OCRRequestQueue. Reason: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'OPTION SQL_SELECT_LIMIT=DEFAULT' at line 1
        at org.apache.activemq.util.IOExceptionSupport.create(IOExceptionSupport.java:33)
        at org.apache.activemq.store.jdbc.JDBCMessageStore.getMessageCount(JDBCMessageStore.java:280)

People have suggested to upgrade to latest mysql driver . I upgraded to mysql-connector-java-5.1.34.jar . Even after that i get the same error.

Please help if anyone has resolved the issue .

Thanks
Reply | Threaded
Open this post in threaded view
|

Re: Mysql 5.6 and activemq

rookie
upgrading the mysql connector java jar to 5.1.23 solved the problem.