Monitoring ActiveMQ with JMX

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Monitoring ActiveMQ with JMX

Andres Tarallo
I´ve managed to make my queue work, messages goes from syslog through
activemq to graylog. Now I´m trying to configure JMX in apache, without
success

On my systemd config (file activemq.service) I´ve added in [Service]

Environment=ACTIVEMQ_SUNJMX_START=-Dcom.sun.managment.jmxremote
-Dcom.sun.managment.port=1099 -Dcom.sun.managment.jmxremote.ssl=false.


Any clues are appreciated, thanks

Andrés
Reply | Threaded
Open this post in threaded view
|

Re: Monitoring ActiveMQ with JMX

Tim Bain
Does netstat show a server socket on port 1099?

If not, does your service script actually use that variable you're
defining? And does it overwrite it and lose your content somewhere before
it starts the ActiveMQ process?

If so, you'll need to tell us more about how you're trying to connect.

Tim

On Fri, Jul 12, 2019, 8:06 AM Andres Tarallo <[hidden email]> wrote:

> I´ve managed to make my queue work, messages goes from syslog through
> activemq to graylog. Now I´m trying to configure JMX in apache, without
> success
>
> On my systemd config (file activemq.service) I´ve added in [Service]
>
> Environment=ACTIVEMQ_SUNJMX_START=-Dcom.sun.managment.jmxremote
> -Dcom.sun.managment.port=1099 -Dcom.sun.managment.jmxremote.ssl=false.
>
>
> Any clues are appreciated, thanks
>
> Andrés
>
Reply | Threaded
Open this post in threaded view
|

Re: Monitoring ActiveMQ with JMX

Andres Tarallo
I've finally manage to get it working. My poor understanding of JMX plus a
misconfiguration prevented from working right. I´ve fixed and tested with
nagios plugin check_jmx.

Thanks,

Andrés



El vie., 12 jul. 2019 a las 23:22, Tim Bain (<[hidden email]>)
escribió:

> Does netstat show a server socket on port 1099?
>
> If not, does your service script actually use that variable you're
> defining? And does it overwrite it and lose your content somewhere before
> it starts the ActiveMQ process?
>
> If so, you'll need to tell us more about how you're trying to connect.
>
> Tim
>
> On Fri, Jul 12, 2019, 8:06 AM Andres Tarallo <[hidden email]> wrote:
>
> > I´ve managed to make my queue work, messages goes from syslog through
> > activemq to graylog. Now I´m trying to configure JMX in apache, without
> > success
> >
> > On my systemd config (file activemq.service) I´ve added in [Service]
> >
> > Environment=ACTIVEMQ_SUNJMX_START=-Dcom.sun.managment.jmxremote
> > -Dcom.sun.managment.port=1099 -Dcom.sun.managment.jmxremote.ssl=false.
> >
> >
> > Any clues are appreciated, thanks
> >
> > Andrés
> >
>