I upgraded AMQ from 5.2.0 to 5.4.0 and many exceptions appear now

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

I upgraded AMQ from 5.2.0 to 5.4.0 and many exceptions appear now

michal.singer
Hi,
I upgraded the AMQ to 5.4.0  from 5.2.0, i changed the activemq.xml to be alphabetic as i understood i should,
I get these exceptions now all the time, on INFO level, which i never got before:
taskExecutorClient-1 [4105026f:12f00165e54:-7f49] 2011-03-29 01:02:17,713 INFO  [org.apache.activemq.broker.TransportConnection.Transport] Transport failed: org.apache.activemq.transport.TransportDisposedIOException: Peer (vm://embeddedbroker#5) disposed.
org.apache.activemq.transport.TransportDisposedIOException: Peer (vm://embeddedbroker#5) disposed.
        at org.apache.activemq.transport.vm.VMTransport.stop(VMTransport.java:159)
        at org.apache.activemq.transport.vm.VMTransportServer$1.stop(VMTransportServer.java:81)
        at org.apache.activemq.transport.TransportFilter.stop(TransportFilter.java:65)
        at org.apache.activemq.transport.TransportFilter.stop(TransportFilter.java:65)
        at org.apache.activemq.transport.ResponseCorrelator.stop(ResponseCorrelator.java:132)
        at org.apache.activemq.util.ServiceSupport.dispose(ServiceSupport.java:43)
        at org.apache.activemq.ActiveMQConnection.close(ActiveMQConnection.java:656)
        at org.springframework.jms.connection.ConnectionFactoryUtils.releaseConnection(ConnectionFactoryUtils.java:81)
        at org.springframework.jms.core.JmsTemplate.execute(JmsTemplate.java:478)
        at org.springframework.jms.core.JmsTemplate.send(JmsTemplate.java:539)
        at com.expand.expandview.infrastructure.messaging.JmsResponseSender.sendNotificationToProducer(JmsResponseSender.java:68)
        at com.expand.expandview.infrastructure.messaging.JmsResponseSender.update(JmsResponseSender.java:56)
        at com.expand.expandview.infrastructure.logics.AbstractLogic.updateObserver(AbstractLogic.java:448)
        at com.expand.expandview.infrastructure.logics.AbstractLogic.data(AbstractLogic.java:350)
        at com.expand.expandview.server.app.logics.user_groups.FetchAllGroupsByUserName.doLogic(FetchAllGroupsByUserName.java:23)
        at com.expand.expandview.infrastructure.logics.AbstractLogic.execute(AbstractLogic.java:111)
        at com.expand.expandview.server.app.logics.ApplicationLogic.execute(ApplicationLogic.java:27)
        at com.expand.expandview.infrastructure.task_executor.TaskExecuterController$1.run(TaskExecuterController.java:83)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:619)



This is the xml i am using:

<?xml version="1.0" encoding="UTF-8"?>
<beans xsi:schemaLocation="http://www.springframework.org/schema/beans           http://www.springframework.org/schema/beans/spring-beans-2.0.xsd          http://activemq.apache.org/schema/activemq-core.xsd          http://activemq.apache.org/camel/schema/spring           http://activemq.apache.org/camel/schema/spring/camel-spring.xsd" xmlns:amq="http://activemq.org/config/1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://www.springframework.org/schema/beans">
<bean class="org.springframework.beans.factory.config.PropertyPlaceholderConfigurer"/>
<broker brokerName="embeddedbroker" useJmx="true" persistent="false" dataDirectory="..\..\work\activemq-data" xmlns="http://activemq.apache.org/schema/core">
<managementContext>
<managementContext connectorPort="1099" jmxDomainName="org.apache.activemq"/>
</managementContext>
<networkConnectors>
<networkConnector name="default-nc" uri="multicast://default"/>
</networkConnectors>
<systemUsage>
<systemUsage>
<memoryUsage>
<memoryUsage limit="20 mb" percentUsageMinDelta="20"/>
</memoryUsage>
<tempUsage>
<tempUsage limit="100 mb"/>
</tempUsage>
</systemUsage>
</systemUsage>
<transportConnectors>
<transportConnector name="tcp" uri="tcp://localhost:61616?wireFormat.maxInactivityDuration=0&amp;soTimeout=60000&amp;connectionTimeout=60000"/>
</transportConnectors>
</broker>
</beans>


Any ideas?

Thanks,

Michal


Reply | Threaded
Open this post in threaded view
|

Re: I upgraded AMQ from 5.2.0 to 5.4.0 and many exceptions appear now

gtully
This is https://issues.apache.org/jira/browse/AMQ-2902

btw, it is always a good idea to google the exception string  or some
variant of it:
http://www.google.com/search?sourceid=chrome&ie=UTF-8&q=Transport+failed%3A+org.apache.activemq.transport.TransportDisposedIOException%3A+Peer

On 29 March 2011 14:01, Michal Singer <[hidden email]> wrote:

> Hi,
> I upgraded the AMQ to 5.4.0  from 5.2.0, i changed the activemq.xml to be alphabetic as i understood i should,
> I get these exceptions now all the time, on INFO level, which i never got before:
> taskExecutorClient-1 [4105026f:12f00165e54:-7f49] 2011-03-29 01:02:17,713 INFO  [org.apache.activemq.broker.TransportConnection.Transport] Transport failed: org.apache.activemq.transport.TransportDisposedIOException: Peer (vm://embeddedbroker#5) disposed.
> org.apache.activemq.transport.TransportDisposedIOException: Peer (vm://embeddedbroker#5) disposed.
>        at org.apache.activemq.transport.vm.VMTransport.stop(VMTransport.java:159)
>        at org.apache.activemq.transport.vm.VMTransportServer$1.stop(VMTransportServer.java:81)
>        at org.apache.activemq.transport.TransportFilter.stop(TransportFilter.java:65)
>        at org.apache.activemq.transport.TransportFilter.stop(TransportFilter.java:65)
>        at org.apache.activemq.transport.ResponseCorrelator.stop(ResponseCorrelator.java:132)
>        at org.apache.activemq.util.ServiceSupport.dispose(ServiceSupport.java:43)
>        at org.apache.activemq.ActiveMQConnection.close(ActiveMQConnection.java:656)
>        at org.springframework.jms.connection.ConnectionFactoryUtils.releaseConnection(ConnectionFactoryUtils.java:81)
>        at org.springframework.jms.core.JmsTemplate.execute(JmsTemplate.java:478)
>        at org.springframework.jms.core.JmsTemplate.send(JmsTemplate.java:539)
>        at com.expand.expandview.infrastructure.messaging.JmsResponseSender.sendNotificationToProducer(JmsResponseSender.java:68)
>        at com.expand.expandview.infrastructure.messaging.JmsResponseSender.update(JmsResponseSender.java:56)
>        at com.expand.expandview.infrastructure.logics.AbstractLogic.updateObserver(AbstractLogic.java:448)
>        at com.expand.expandview.infrastructure.logics.AbstractLogic.data(AbstractLogic.java:350)
>        at com.expand.expandview.server.app.logics.user_groups.FetchAllGroupsByUserName.doLogic(FetchAllGroupsByUserName.java:23)
>        at com.expand.expandview.infrastructure.logics.AbstractLogic.execute(AbstractLogic.java:111)
>        at com.expand.expandview.server.app.logics.ApplicationLogic.execute(ApplicationLogic.java:27)
>        at com.expand.expandview.infrastructure.task_executor.TaskExecuterController$1.run(TaskExecuterController.java:83)
>        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
>        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
>        at java.lang.Thread.run(Thread.java:619)
>
>
>
> This is the xml i am using:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <beans xsi:schemaLocation="http://www.springframework.org/schema/beans           http://www.springframework.org/schema/beans/spring-beans-2.0.xsd          http://activemq.apache.org/schema/activemq-core.xsd          http://activemq.apache.org/camel/schema/spring           http://activemq.apache.org/camel/schema/spring/camel-spring.xsd" xmlns:amq="http://activemq.org/config/1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://www.springframework.org/schema/beans">
> <bean class="org.springframework.beans.factory.config.PropertyPlaceholderConfigurer"/>
> <broker brokerName="embeddedbroker" useJmx="true" persistent="false" dataDirectory="..\..\work\activemq-data" xmlns="http://activemq.apache.org/schema/core">
> <managementContext>
> <managementContext connectorPort="1099" jmxDomainName="org.apache.activemq"/>
> </managementContext>
> <networkConnectors>
> <networkConnector name="default-nc" uri="multicast://default"/>
> </networkConnectors>
> <systemUsage>
> <systemUsage>
> <memoryUsage>
> <memoryUsage limit="20 mb" percentUsageMinDelta="20"/>
> </memoryUsage>
> <tempUsage>
> <tempUsage limit="100 mb"/>
> </tempUsage>
> </systemUsage>
> </systemUsage>
> <transportConnectors>
> <transportConnector name="tcp" uri="tcp://localhost:61616?wireFormat.maxInactivityDuration=0&amp;soTimeout=60000&amp;connectionTimeout=60000"/>
> </transportConnectors>
> </broker>
> </beans>
>
>
> Any ideas?
>
> Thanks,
>
> Michal
>
>
>



--
http://blog.garytully.com
http://fusesource.com
Reply | Threaded
Open this post in threaded view
|

RE: I upgraded AMQ from 5.2.0 to 5.4.0 and many exceptions appear now

michal.singer
Hi, due to the problems I deteceted I tried to upgrade but every build causes problems. I tried to upgrade to 5.4.2 and all my application gets stuck.
I see in the activemq log, this message appears over and over:
INFO  [org.apache.activemq.xbean.XBeanBrokerFactory$1] Refreshing org.apache.activemq.xbean.XBeanBrokerFactory$1@535e27: display name [org.apache.activemq.xbean.XBeanBrokerFactory$1@535e27]; startup date [Wed Mar 30 01:02:31 VET 2011]; root of context hierarchy

I have no idea why it does not work. Is there anything else I need to do besides update the jar from
activemq-all-5.2.0.jar to activemq-all-5.4.2.jar, and update the activemq.xml file to be in alphabetic order?

Thanks, Michal

-----Original Message-----
From: Gary Tully [mailto:[hidden email]]
Sent: ג 29 מרץ 2011 15:18
To: [hidden email]
Subject: Re: I upgraded AMQ from 5.2.0 to 5.4.0 and many exceptions appear now

This is https://issues.apache.org/jira/browse/AMQ-2902

btw, it is always a good idea to google the exception string  or some
variant of it:
http://www.google.com/search?sourceid=chrome&ie=UTF-8&q=Transport+failed%3A+org.apache.activemq.transport.TransportDisposedIOException%3A+Peer

On 29 March 2011 14:01, Michal Singer <[hidden email]> wrote:

> Hi,
> I upgraded the AMQ to 5.4.0  from 5.2.0, i changed the activemq.xml to be alphabetic as i understood i should,
> I get these exceptions now all the time, on INFO level, which i never got before:
> taskExecutorClient-1 [4105026f:12f00165e54:-7f49] 2011-03-29 01:02:17,713 INFO  [org.apache.activemq.broker.TransportConnection.Transport] Transport failed: org.apache.activemq.transport.TransportDisposedIOException: Peer (vm://embeddedbroker#5) disposed.
> org.apache.activemq.transport.TransportDisposedIOException: Peer (vm://embeddedbroker#5) disposed.
>        at org.apache.activemq.transport.vm.VMTransport.stop(VMTransport.java:159)
>        at org.apache.activemq.transport.vm.VMTransportServer$1.stop(VMTransportServer.java:81)
>        at org.apache.activemq.transport.TransportFilter.stop(TransportFilter.java:65)
>        at org.apache.activemq.transport.TransportFilter.stop(TransportFilter.java:65)
>        at org.apache.activemq.transport.ResponseCorrelator.stop(ResponseCorrelator.java:132)
>        at org.apache.activemq.util.ServiceSupport.dispose(ServiceSupport.java:43)
>        at org.apache.activemq.ActiveMQConnection.close(ActiveMQConnection.java:656)
>        at org.springframework.jms.connection.ConnectionFactoryUtils.releaseConnection(ConnectionFactoryUtils.java:81)
>        at org.springframework.jms.core.JmsTemplate.execute(JmsTemplate.java:478)
>        at org.springframework.jms.core.JmsTemplate.send(JmsTemplate.java:539)
>        at com.expand.expandview.infrastructure.messaging.JmsResponseSender.sendNotificationToProducer(JmsResponseSender.java:68)
>        at com.expand.expandview.infrastructure.messaging.JmsResponseSender.update(JmsResponseSender.java:56)
>        at com.expand.expandview.infrastructure.logics.AbstractLogic.updateObserver(AbstractLogic.java:448)
>        at com.expand.expandview.infrastructure.logics.AbstractLogic.data(AbstractLogic.java:350)
>        at com.expand.expandview.server.app.logics.user_groups.FetchAllGroupsByUserName.doLogic(FetchAllGroupsByUserName.java:23)
>        at com.expand.expandview.infrastructure.logics.AbstractLogic.execute(AbstractLogic.java:111)
>        at com.expand.expandview.server.app.logics.ApplicationLogic.execute(ApplicationLogic.java:27)
>        at com.expand.expandview.infrastructure.task_executor.TaskExecuterController$1.run(TaskExecuterController.java:83)
>        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
>        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
>        at java.lang.Thread.run(Thread.java:619)
>
>
>
> This is the xml i am using:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <beans xsi:schemaLocation="http://www.springframework.org/schema/beans           http://www.springframework.org/schema/beans/spring-beans-2.0.xsd          http://activemq.apache.org/schema/activemq-core.xsd          http://activemq.apache.org/camel/schema/spring           http://activemq.apache.org/camel/schema/spring/camel-spring.xsd" xmlns:amq="http://activemq.org/config/1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://www.springframework.org/schema/beans">
> <bean class="org.springframework.beans.factory.config.PropertyPlaceholderConfigurer"/>
> <broker brokerName="embeddedbroker" useJmx="true" persistent="false" dataDirectory="..\..\work\activemq-data" xmlns="http://activemq.apache.org/schema/core">
> <managementContext>
> <managementContext connectorPort="1099" jmxDomainName="org.apache.activemq"/>
> </managementContext>
> <networkConnectors>
> <networkConnector name="default-nc" uri="multicast://default"/>
> </networkConnectors>
> <systemUsage>
> <systemUsage>
> <memoryUsage>
> <memoryUsage limit="20 mb" percentUsageMinDelta="20"/>
> </memoryUsage>
> <tempUsage>
> <tempUsage limit="100 mb"/>
> </tempUsage>
> </systemUsage>
> </systemUsage>
> <transportConnectors>
> <transportConnector name="tcp" uri="tcp://localhost:61616?wireFormat.maxInactivityDuration=0&amp;soTimeout=60000&amp;connectionTimeout=60000"/>
> </transportConnectors>
> </broker>
> </beans>
>
>
> Any ideas?
>
> Thanks,
>
> Michal
>
>
>



--
http://blog.garytully.com
http://fusesource.com
Reply | Threaded
Open this post in threaded view
|

Re: I upgraded AMQ from 5.2.0 to 5.4.0 and many exceptions appear now

gtully
try comparing your config file with the configuration in
conf/activemq.xml - it looks like your schema locations are a little
off. Also that reference to config/1.0 is obsolete.

From conf/activemq.xml a typical header is:

<beans
  xmlns="http://www.springframework.org/schema/beans"
  xmlns:amq="http://activemq.apache.org/schema/core"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://www.springframework.org/schema/beans
http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
  http://activemq.apache.org/schema/core
http://activemq.apache.org/schema/core/activemq-core.xsd">

2011/3/30 Michal Singer <[hidden email]>:

> Hi, due to the problems I deteceted I tried to upgrade but every build causes problems. I tried to upgrade to 5.4.2 and all my application gets stuck.
> I see in the activemq log, this message appears over and over:
> INFO  [org.apache.activemq.xbean.XBeanBrokerFactory$1] Refreshing org.apache.activemq.xbean.XBeanBrokerFactory$1@535e27: display name [org.apache.activemq.xbean.XBeanBrokerFactory$1@535e27]; startup date [Wed Mar 30 01:02:31 VET 2011]; root of context hierarchy
>
> I have no idea why it does not work. Is there anything else I need to do besides update the jar from
> activemq-all-5.2.0.jar to activemq-all-5.4.2.jar, and update the activemq.xml file to be in alphabetic order?
>
> Thanks, Michal
>
> -----Original Message-----
> From: Gary Tully [mailto:[hidden email]]
> Sent: ג 29 מרץ 2011 15:18
> To: [hidden email]
> Subject: Re: I upgraded AMQ from 5.2.0 to 5.4.0 and many exceptions appear now
>
> This is https://issues.apache.org/jira/browse/AMQ-2902
>
> btw, it is always a good idea to google the exception string  or some
> variant of it:
> http://www.google.com/search?sourceid=chrome&ie=UTF-8&q=Transport+failed%3A+org.apache.activemq.transport.TransportDisposedIOException%3A+Peer
>
> On 29 March 2011 14:01, Michal Singer <[hidden email]> wrote:
>> Hi,
>> I upgraded the AMQ to 5.4.0  from 5.2.0, i changed the activemq.xml to be alphabetic as i understood i should,
>> I get these exceptions now all the time, on INFO level, which i never got before:
>> taskExecutorClient-1 [4105026f:12f00165e54:-7f49] 2011-03-29 01:02:17,713 INFO  [org.apache.activemq.broker.TransportConnection.Transport] Transport failed: org.apache.activemq.transport.TransportDisposedIOException: Peer (vm://embeddedbroker#5) disposed.
>> org.apache.activemq.transport.TransportDisposedIOException: Peer (vm://embeddedbroker#5) disposed.
>>        at org.apache.activemq.transport.vm.VMTransport.stop(VMTransport.java:159)
>>        at org.apache.activemq.transport.vm.VMTransportServer$1.stop(VMTransportServer.java:81)
>>        at org.apache.activemq.transport.TransportFilter.stop(TransportFilter.java:65)
>>        at org.apache.activemq.transport.TransportFilter.stop(TransportFilter.java:65)
>>        at org.apache.activemq.transport.ResponseCorrelator.stop(ResponseCorrelator.java:132)
>>        at org.apache.activemq.util.ServiceSupport.dispose(ServiceSupport.java:43)
>>        at org.apache.activemq.ActiveMQConnection.close(ActiveMQConnection.java:656)
>>        at org.springframework.jms.connection.ConnectionFactoryUtils.releaseConnection(ConnectionFactoryUtils.java:81)
>>        at org.springframework.jms.core.JmsTemplate.execute(JmsTemplate.java:478)
>>        at org.springframework.jms.core.JmsTemplate.send(JmsTemplate.java:539)
>>        at com.expand.expandview.infrastructure.messaging.JmsResponseSender.sendNotificationToProducer(JmsResponseSender.java:68)
>>        at com.expand.expandview.infrastructure.messaging.JmsResponseSender.update(JmsResponseSender.java:56)
>>        at com.expand.expandview.infrastructure.logics.AbstractLogic.updateObserver(AbstractLogic.java:448)
>>        at com.expand.expandview.infrastructure.logics.AbstractLogic.data(AbstractLogic.java:350)
>>        at com.expand.expandview.server.app.logics.user_groups.FetchAllGroupsByUserName.doLogic(FetchAllGroupsByUserName.java:23)
>>        at com.expand.expandview.infrastructure.logics.AbstractLogic.execute(AbstractLogic.java:111)
>>        at com.expand.expandview.server.app.logics.ApplicationLogic.execute(ApplicationLogic.java:27)
>>        at com.expand.expandview.infrastructure.task_executor.TaskExecuterController$1.run(TaskExecuterController.java:83)
>>        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
>>        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
>>        at java.lang.Thread.run(Thread.java:619)
>>
>>
>>
>> This is the xml i am using:
>>
>> <?xml version="1.0" encoding="UTF-8"?>
>> <beans xsi:schemaLocation="http://www.springframework.org/schema/beans           http://www.springframework.org/schema/beans/spring-beans-2.0.xsd          http://activemq.apache.org/schema/activemq-core.xsd          http://activemq.apache.org/camel/schema/spring           http://activemq.apache.org/camel/schema/spring/camel-spring.xsd" xmlns:amq="http://activemq.org/config/1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://www.springframework.org/schema/beans">
>> <bean class="org.springframework.beans.factory.config.PropertyPlaceholderConfigurer"/>
>> <broker brokerName="embeddedbroker" useJmx="true" persistent="false" dataDirectory="..\..\work\activemq-data" xmlns="http://activemq.apache.org/schema/core">
>> <managementContext>
>> <managementContext connectorPort="1099" jmxDomainName="org.apache.activemq"/>
>> </managementContext>
>> <networkConnectors>
>> <networkConnector name="default-nc" uri="multicast://default"/>
>> </networkConnectors>
>> <systemUsage>
>> <systemUsage>
>> <memoryUsage>
>> <memoryUsage limit="20 mb" percentUsageMinDelta="20"/>
>> </memoryUsage>
>> <tempUsage>
>> <tempUsage limit="100 mb"/>
>> </tempUsage>
>> </systemUsage>
>> </systemUsage>
>> <transportConnectors>
>> <transportConnector name="tcp" uri="tcp://localhost:61616?wireFormat.maxInactivityDuration=0&amp;soTimeout=60000&amp;connectionTimeout=60000"/>
>> </transportConnectors>
>> </broker>
>> </beans>
>>
>>
>> Any ideas?
>>
>> Thanks,
>>
>> Michal
>>
>>
>>
>
>
>
> --
> http://blog.garytully.com
> http://fusesource.com
>



--
http://blog.garytully.com
http://fusesource.com