Quantcast

Failed to start jmx connector

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Failed to start jmx connector

Mohit Anchlia
I am using 5.4 and my config is

<?xml version="1.0" encoding="UTF-8"?>
<beans
  xmlns="http://www.springframework.org/schema/beans"
  xmlns:amq="http://activemq.apache.org/schema/core"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://www.springframework.org/schema/beans
http://www.springframework.org/schema/beans/spring-beans-3.0.xsd
  http://activemq.apache.org/schema/core
http://activemq.apache.org/schema/core/activemq-core.xsd">

  <!--  lets create an embedded ActiveMQ Broker -->
  <amq:broker id="ApiBroker" useJmx="true" persistent="false">
    <amq:managementContext>
    <amq:managementContext connectorPort="3012" jmxDomainName="api.domain"/>
        </amq:managementContext>
    <amq:transportConnectors>
      <amq:transportConnector uri="tcp://localhost:0" />
    </amq:transportConnectors>
  </amq:broker>

   <!--  ActiveMQ destinations to use  -->
  <amq:queue id="destination"
physicalName="org.apache.activemq.spring.Test.spring.embedded"/>

  <!-- JMS ConnectionFactory to use, configuring the embedded broker
using XML -->
  <!-- <amq:connectionFactory id="ApiJmsFactory"
brokerURL="vm://apihost"/>     -->

      <bean id="ApiJmsFactory"
class="org.apache.activemq.ActiveMQConnectionFactory"
depends-on="ApiBroker">
        <property name="brokerURL" value="vm://apihost"/>
     </bean>

</beans>

and I keep getting this even though I have managementContext defined.
Any suggestions?

----


WARN  org.apache.activemq.broker.jmx.ManagementContext [JMX
connector]: Failed to start jmx connector: Cannot bind to URL
[rmi://localhost:1099/jmxrmi]: javax.naming.NameAlreadyBoundException:
jmxrmi [Root exception is java.rmi.AlreadyBoundException: jmxrmi]
Failed to start jmx connector: Cannot bind to URL
[rmi://localhost:1099/jmxrmi]: javax.naming.NameAlreadyBoundException:
jmxrmi [Root exception is java.rmi.AlreadyBoundException: jmxrmi]
WARN  org.apache.activemq.broker.jmx.ManagementContext [JMX
connector]: Failed to start jmx connector: Cannot bind to URL
[rmi://localhost:1099/jmxrmi]: javax.naming.NameAlreadyBoundException:
jmxrmi [Root exception is java.rmi.AlreadyBoundException: jmxrmi]
Failed to start jmx connector: Cannot bind to URL
[rmi://localhost:1099/jmxrmi]: javax.naming.NameAlreadyBoundException:
jmxrmi [Root exception is java.rmi.AlreadyBoundException: jmxrmi]
INFO  2011-09-28 16:43:09,072 [WrapperListener_start_runner]
org.mule.module.launcher.DeploymentService:
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Failed to start jmx connector

Torsten Mielke-2
I wonder, does it work when you use this configuration:

<managementContext>
  <managementContext createConnector="true" connectorPort="3012"/>
</managementContext>


There is generally no need to set useJmx="true" in the broker element. At least I never specify it.

Regards,

Torsten Mielke
[hidden email]
[hidden email]



Loading...