Connecting from SAP XI to ActiveMQ

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Connecting from SAP XI to ActiveMQ

mslopar
Hi,
I need to connect from SAP XI to ActiveMQ ver. 5.1.0. SAP XI supports this by deploying some ActiveMQ driver to XI. So my question is, where to find this driver?

Thanks
Reply | Threaded
Open this post in threaded view
|

Re: Connecting from SAP XI to ActiveMQ

joe_fernandez
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Connecting from SAP XI to ActiveMQ

mslopar
I saw this article and I'm not sure I configured everything correctly. I'm getting error message:

Error during channel initialization; exception trace: java.lang.UnsupportedClassVersionError: org/apache/activemq/ActiveMQConnectionFactory (Unsupported major.minor version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
at com.sap.engine.frame.core.load.ResourceLoader.loadLocalClass(ResourceLoader.java:262)
.... ?!?

Which means what, that XI JDK 1.3 is not able to use this class?
Reply | Threaded
Open this post in threaded view
|

Re: Connecting from SAP XI to ActiveMQ

JLhr
Hi,

We have a SAP PI 7.1, with JAVA 1.5 and when uploading the latest driver
version  of ActiveMQ, we get the following error:

Error while starting channel: org/apache/activemq/ActiveMQConnectionFactory
has been compiled by a more recent version of the Java Runtime (class file
version 52.0), this version of the Java Runtime only recognizes class file
versions up to 49.0

@ ActiveMQ / Forum: Please, can you provide me with a driver version that is
compatible with the JAVA version or some other solution?

Thanks, Regards,
Jose



--
Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html
Reply | Threaded
Open this post in threaded view
|

Re: Connecting from SAP XI to ActiveMQ

jbertram
Check out the documentation [1].  In short, ActiveMQ 5.7 looks to be the
last version that supports Java 5 (JDK 1.5) so you'll need to use a client
from that version. I would expect later releases of the broker to be
backwards compatible with older clients.

Aside from that, I recommend you move to a later version of Java. According
to Wikipedia [2] public support and security updates for Java 1.5 ended in
November 2009. Paid security updates for Oracle customers ended in April
2015. You're using a really old platform at this point which is both a
support and security risk.


Justin

[1] https://activemq.apache.org/what-platforms-does-activemq-support
[2] https://en.wikipedia.org/wiki/Java_version_history#J2SE_5.0

On Thu, Dec 12, 2019 at 9:53 AM JLhr <[hidden email]> wrote:

> Hi,
>
> We have a SAP PI 7.1, with JAVA 1.5 and when uploading the latest driver
> version  of ActiveMQ, we get the following error:
>
> Error while starting channel: org/apache/activemq/ActiveMQConnectionFactory
> has been compiled by a more recent version of the Java Runtime (class file
> version 52.0), this version of the Java Runtime only recognizes class file
> versions up to 49.0
>
> @ ActiveMQ / Forum: Please, can you provide me with a driver version that
> is
> compatible with the JAVA version or some other solution?
>
> Thanks, Regards,
> Jose
>
>
>
> --
> Sent from:
> http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Connecting from SAP XI to ActiveMQ

Tim Bain
To add to Justin's points, that old JRE is forcing you to use an old
version of ActiveMQ, for which many bugs were later fixed. Upgrade to a
more modern JRE (probably Java 8, unless SAP PI 7.1 supports Java 9+, but
that certainly isn't guaranteed given that it was released in 2008), and
then upgrade to a recent version of ActiveMQ.

Tim

On Thu, Dec 12, 2019, 9:36 AM Justin Bertram <[hidden email]> wrote:

> Check out the documentation [1].  In short, ActiveMQ 5.7 looks to be the
> last version that supports Java 5 (JDK 1.5) so you'll need to use a client
> from that version. I would expect later releases of the broker to be
> backwards compatible with older clients.
>
> Aside from that, I recommend you move to a later version of Java. According
> to Wikipedia [2] public support and security updates for Java 1.5 ended in
> November 2009. Paid security updates for Oracle customers ended in April
> 2015. You're using a really old platform at this point which is both a
> support and security risk.
>
>
> Justin
>
> [1] https://activemq.apache.org/what-platforms-does-activemq-support
> [2] https://en.wikipedia.org/wiki/Java_version_history#J2SE_5.0
>
> On Thu, Dec 12, 2019 at 9:53 AM JLhr <[hidden email]> wrote:
>
> > Hi,
> >
> > We have a SAP PI 7.1, with JAVA 1.5 and when uploading the latest driver
> > version  of ActiveMQ, we get the following error:
> >
> > Error while starting channel:
> org/apache/activemq/ActiveMQConnectionFactory
> > has been compiled by a more recent version of the Java Runtime (class
> file
> > version 52.0), this version of the Java Runtime only recognizes class
> file
> > versions up to 49.0
> >
> > @ ActiveMQ / Forum: Please, can you provide me with a driver version that
> > is
> > compatible with the JAVA version or some other solution?
> >
> > Thanks, Regards,
> > Jose
> >
> >
> >
> > --
> > Sent from:
> > http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html
> >
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: Connecting from SAP XI to ActiveMQ

JLhr
Hi,

The JAVA update is not recommended, for the version we have of SAP PI 7.1
and for that reason I have contacted the forum.

Thanks!!

Regards,
Jose



--
Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html