Building ActiveMQ

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Building ActiveMQ

skis
Hey All,
I am trying to build the ActiveMQ source code and ran into compilation
failures. Maven complains of not being able to find a certain dependency.

Verified the .m2 settings, local .m2 repository directory and confirmed
that the required artifact is available.

I followed the directions at http://activemq.apache.org/building.html

Could you offer some suggestion to resolve below?

[ERROR] Failed to execute goal on project activemq-kahadb-store: Could not
resolve dependencies for project
org.apache.activemq:activemq-kahadb-store:jar:5.15.1-SNAPSHOT: Could not
find artifact org.apache.activemq:activemq-broker:jar:tests:5.15.1-SNAPSHOT
-> [Help 1]

NOTE: I did not make any changes to the POM or any configuration therein.

Thanks
skis
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Building ActiveMQ

christopher.l.shannon
Have you checked out the lasted actievmq-5.15.x branch? Master is currently
5.16.0-SNAPSHOT and activemq-5.15.x is set to 5.15.1-SNAPSHOT.  I just
tested and I was able to compile on both (mvn clean install -DskipTests)
without issue.

On Sun, Jul 9, 2017 at 1:31 PM, skis <[hidden email]> wrote:

> Hey All,
> I am trying to build the ActiveMQ source code and ran into compilation
> failures. Maven complains of not being able to find a certain dependency.
>
> Verified the .m2 settings, local .m2 repository directory and confirmed
> that the required artifact is available.
>
> I followed the directions at http://activemq.apache.org/building.html
>
> Could you offer some suggestion to resolve below?
>
> [ERROR] Failed to execute goal on project activemq-kahadb-store: Could not
> resolve dependencies for project
> org.apache.activemq:activemq-kahadb-store:jar:5.15.1-SNAPSHOT: Could not
> find artifact org.apache.activemq:activemq-broker:jar:tests:5.15.1-
> SNAPSHOT
> -> [Help 1]
>
> NOTE: I did not make any changes to the POM or any configuration therein.
>
> Thanks
> skis
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Building ActiveMQ

skis
Thanks Christopher, Let me cleanup try again.

On Jul 10, 2017 9:09 AM, "Christopher Shannon" <christopher.l.shannon@gmail.
com> wrote:

Have you checked out the lasted actievmq-5.15.x branch? Master is currently
5.16.0-SNAPSHOT and activemq-5.15.x is set to 5.15.1-SNAPSHOT.  I just
tested and I was able to compile on both (mvn clean install -DskipTests)
without issue.

On Sun, Jul 9, 2017 at 1:31 PM, skis <[hidden email]> wrote:

> Hey All,
> I am trying to build the ActiveMQ source code and ran into compilation
> failures. Maven complains of not being able to find a certain dependency.
>
> Verified the .m2 settings, local .m2 repository directory and confirmed
> that the required artifact is available.
>
> I followed the directions at http://activemq.apache.org/building.html
>
> Could you offer some suggestion to resolve below?
>
> [ERROR] Failed to execute goal on project activemq-kahadb-store: Could not
> resolve dependencies for project
> org.apache.activemq:activemq-kahadb-store:jar:5.15.1-SNAPSHOT: Could not
> find artifact org.apache.activemq:activemq-broker:jar:tests:5.15.1-
> SNAPSHOT
> -> [Help 1]
>
> NOTE: I did not make any changes to the POM or any configuration therein.
>
> Thanks
> skis
>
Loading...