Artemis Connection failure has been detected

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Artemis Connection failure has been detected

Raul Valdoleiros
Hi,

I'm trying to create a dynamic cluster of artemis brokers. I'm getting the following messages when I shutdown one of the brokers.

17:24:47,747 WARN  [org.apache.activemq.artemis.core.client] AMQ212037: Connection failure has been detected: AMQ119015: The connection was disconnected because of server shutdown [code=DISCONNECTED]
17:24:47,763 WARN  [org.apache.activemq.artemis.core.client] AMQ212037: Connection failure has been detected: AMQ119015: The connection was disconnected because of server shutdown [code=DISCONNECTED]
17:24:47,755 WARN  [org.apache.activemq.artemis.core.client] AMQ212037: Connection failure has been detected: AMQ119015: The connection was disconnected because of server shutdown [code=DISCONNECTED]
17:24:47,769 WARN  [org.apache.activemq.artemis.core.server] AMQ222095: Connection failed with failedOver=false
17:24:47,797 WARN  [org.apache.activemq.artemis.core.server] AMQ222095: Connection failed with failedOver=false
17:24:47,801 INFO  [org.apache.activemq.artemis.core.server] AMQ221029: stopped bridge $.artemis.internal.sf.my-cluster.23bc5035-d11d-11e7-b017-8c705a641428
17:24:57,973 WARN  [org.apache.activemq.artemis.core.client] AMQ212034: There are more than one servers on the network broadcasting the same node id. You will see this message exactly once (per node) if a node is restarted, in which case it can be safely ignored. But if it is logged continuously it means you really do have more than one node on the same network active concurrently with the same node id. This could occur if you have a backup node active at the same time as its live node. nodeID=23bc5035-d11d-11e7-b017-8c705a641428

I suspect that this behavior makes the brokers lost messages.

I attached the brokers configurations. Can someone help me understand what is wrong?

Thanks in advance,
Raul


Reply | Threaded
Open this post in threaded view
|

Re: Artemis Connection failure has been detected

mnovak
Hi,

those messages are normal when server in Artemis cluster is shutdown. You will not loose messages if you start the broker again. Note that messages are usually load-balanced (distributed) to all nodes in cluster in round robin fashion. So shutting down node in cluster (without proper scale down) will cause that messages on shutdown node cannot be processed.

Thanks,
Mirek

----- Original Message -----

> From: "Raul Valdoleiros" <[hidden email]>
> To: [hidden email]
> Sent: Thursday, January 25, 2018 6:34:11 PM
> Subject: Artemis Connection failure has been detected
>
> Hi,
>
> I'm trying to create a dynamic cluster of artemis brokers. I'm getting the
> following messages when I shutdown one of the brokers.
>
> 17:24:47,747 WARN  [org.apache.activemq.artemis.core.client] AMQ212037:
> Connection failure has been detected: AMQ119015: The connection was
> disconnected because of server shutdown [code=DISCONNECTED]
> 17:24:47,763 WARN  [org.apache.activemq.artemis.core.client] AMQ212037:
> Connection failure has been detected: AMQ119015: The connection was
> disconnected because of server shutdown [code=DISCONNECTED]
> 17:24:47,755 WARN  [org.apache.activemq.artemis.core.client] AMQ212037:
> Connection failure has been detected: AMQ119015: The connection was
> disconnected because of server shutdown [code=DISCONNECTED]
> 17:24:47,769 WARN  [org.apache.activemq.artemis.core.server] AMQ222095:
> Connection failed with failedOver=false
> 17:24:47,797 WARN  [org.apache.activemq.artemis.core.server] AMQ222095:
> Connection failed with failedOver=false
> 17:24:47,801 INFO  [org.apache.activemq.artemis.core.server] AMQ221029:
> stopped bridge
> $.artemis.internal.sf.my-cluster.23bc5035-d11d-11e7-b017-8c705a641428
> 17:24:57,973 WARN  [org.apache.activemq.artemis.core.client] AMQ212034:
> There are more than one servers on the network broadcasting the same node
> id. You will see this message exactly once (per node) if a node is
> restarted, in which case it can be safely ignored. But if it is logged
> continuously it means you really do have more than one node on the same
> network active concurrently with the same node id. This could occur if you
> have a backup node active at the same time as its live node.
> nodeID=23bc5035-d11d-11e7-b017-8c705a641428
>
> I suspect that this behavior makes the brokers lost messages.
>
> I attached the brokers configurations. Can someone help me understand what
> is wrong?
>
> Thanks in advance,
> Raul
>
Reply | Threaded
Open this post in threaded view
|

Re: Artemis Connection failure has been detected

nigro_franz
Hi,

as Miroslav said, that warnings aren't a sign of any lost message, but I
agree that they are somehow scary :)
Maybe could worth to lower the log level to INFO.

Thanks,
Franz


Il giorno ven 26 gen 2018 alle ore 09:28 Miroslav Novak <[hidden email]>
ha scritto:

> Hi,
>
> those messages are normal when server in Artemis cluster is shutdown. You
> will not loose messages if you start the broker again. Note that messages
> are usually load-balanced (distributed) to all nodes in cluster in round
> robin fashion. So shutting down node in cluster (without proper scale down)
> will cause that messages on shutdown node cannot be processed.
>
> Thanks,
> Mirek
>
> ----- Original Message -----
> > From: "Raul Valdoleiros" <[hidden email]>
> > To: [hidden email]
> > Sent: Thursday, January 25, 2018 6:34:11 PM
> > Subject: Artemis Connection failure has been detected
> >
> > Hi,
> >
> > I'm trying to create a dynamic cluster of artemis brokers. I'm getting
> the
> > following messages when I shutdown one of the brokers.
> >
> > 17:24:47,747 WARN  [org.apache.activemq.artemis.core.client] AMQ212037:
> > Connection failure has been detected: AMQ119015: The connection was
> > disconnected because of server shutdown [code=DISCONNECTED]
> > 17:24:47,763 WARN  [org.apache.activemq.artemis.core.client] AMQ212037:
> > Connection failure has been detected: AMQ119015: The connection was
> > disconnected because of server shutdown [code=DISCONNECTED]
> > 17:24:47,755 WARN  [org.apache.activemq.artemis.core.client] AMQ212037:
> > Connection failure has been detected: AMQ119015: The connection was
> > disconnected because of server shutdown [code=DISCONNECTED]
> > 17:24:47,769 WARN  [org.apache.activemq.artemis.core.server] AMQ222095:
> > Connection failed with failedOver=false
> > 17:24:47,797 WARN  [org.apache.activemq.artemis.core.server] AMQ222095:
> > Connection failed with failedOver=false
> > 17:24:47,801 INFO  [org.apache.activemq.artemis.core.server] AMQ221029:
> > stopped bridge
> > $.artemis.internal.sf.my-cluster.23bc5035-d11d-11e7-b017-8c705a641428
> > 17:24:57,973 WARN  [org.apache.activemq.artemis.core.client] AMQ212034:
> > There are more than one servers on the network broadcasting the same node
> > id. You will see this message exactly once (per node) if a node is
> > restarted, in which case it can be safely ignored. But if it is logged
> > continuously it means you really do have more than one node on the same
> > network active concurrently with the same node id. This could occur if
> you
> > have a backup node active at the same time as its live node.
> > nodeID=23bc5035-d11d-11e7-b017-8c705a641428
> >
> > I suspect that this behavior makes the brokers lost messages.
> >
> > I attached the brokers configurations. Can someone help me understand
> what
> > is wrong?
> >
> > Thanks in advance,
> > Raul
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: Artemis Connection failure has been detected

Raul Valdoleiros
Hi,

Thanks for your help :)

2018-01-26 9:10 GMT+00:00 Francesco Nigro <[hidden email]>:

> Hi,
>
> as Miroslav said, that warnings aren't a sign of any lost message, but I
> agree that they are somehow scary :)
> Maybe could worth to lower the log level to INFO.
>
> Thanks,
> Franz
>
>
> Il giorno ven 26 gen 2018 alle ore 09:28 Miroslav Novak <[hidden email]
> >
> ha scritto:
>
> > Hi,
> >
> > those messages are normal when server in Artemis cluster is shutdown. You
> > will not loose messages if you start the broker again. Note that messages
> > are usually load-balanced (distributed) to all nodes in cluster in round
> > robin fashion. So shutting down node in cluster (without proper scale
> down)
> > will cause that messages on shutdown node cannot be processed.
> >
> > Thanks,
> > Mirek
> >
> > ----- Original Message -----
> > > From: "Raul Valdoleiros" <[hidden email]>
> > > To: [hidden email]
> > > Sent: Thursday, January 25, 2018 6:34:11 PM
> > > Subject: Artemis Connection failure has been detected
> > >
> > > Hi,
> > >
> > > I'm trying to create a dynamic cluster of artemis brokers. I'm getting
> > the
> > > following messages when I shutdown one of the brokers.
> > >
> > > 17:24:47,747 WARN  [org.apache.activemq.artemis.core.client]
> AMQ212037:
> > > Connection failure has been detected: AMQ119015: The connection was
> > > disconnected because of server shutdown [code=DISCONNECTED]
> > > 17:24:47,763 WARN  [org.apache.activemq.artemis.core.client]
> AMQ212037:
> > > Connection failure has been detected: AMQ119015: The connection was
> > > disconnected because of server shutdown [code=DISCONNECTED]
> > > 17:24:47,755 WARN  [org.apache.activemq.artemis.core.client]
> AMQ212037:
> > > Connection failure has been detected: AMQ119015: The connection was
> > > disconnected because of server shutdown [code=DISCONNECTED]
> > > 17:24:47,769 WARN  [org.apache.activemq.artemis.core.server]
> AMQ222095:
> > > Connection failed with failedOver=false
> > > 17:24:47,797 WARN  [org.apache.activemq.artemis.core.server]
> AMQ222095:
> > > Connection failed with failedOver=false
> > > 17:24:47,801 INFO  [org.apache.activemq.artemis.core.server]
> AMQ221029:
> > > stopped bridge
> > > $.artemis.internal.sf.my-cluster.23bc5035-d11d-11e7-b017-8c705a641428
> > > 17:24:57,973 WARN  [org.apache.activemq.artemis.core.client]
> AMQ212034:
> > > There are more than one servers on the network broadcasting the same
> node
> > > id. You will see this message exactly once (per node) if a node is
> > > restarted, in which case it can be safely ignored. But if it is logged
> > > continuously it means you really do have more than one node on the same
> > > network active concurrently with the same node id. This could occur if
> > you
> > > have a backup node active at the same time as its live node.
> > > nodeID=23bc5035-d11d-11e7-b017-8c705a641428
> > >
> > > I suspect that this behavior makes the brokers lost messages.
> > >
> > > I attached the brokers configurations. Can someone help me understand
> > what
> > > is wrong?
> > >
> > > Thanks in advance,
> > > Raul
> > >
> >
>