Artemis 2.3 upgrading to 2.4 issues

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Artemis 2.3 upgrading to 2.4 issues

Spaction
User guide states that upgrading between versions should be as simple as
changing the Artemis version in the etc/artemis.profile file.

There are several differences between 2.4 and 2.3 that make this not
possible.

2.4 requires etc/management.xml to be created.
Additionally jolokia-access.xml is created but not required.

bootstrap.xml needs the web section updated to remove the url="jolokia"
line.

Additionally after updating and adding, starting up of the service then
reports insufficient roles/credentials everywhere on the jolokia UI when
accessing remotely (cannot test locally as running on a linux box).

This is the same when using the 2.4 instance instead of the upgraded one
when trying to view anything remotely from the

Please update the documentation to correctly indicate how to upgrade Artemis
versions.



--
Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html
Reply | Threaded
Open this post in threaded view
|

Re: Artemis 2.3 upgrading to 2.4 issues

clebertsuconic
We aim to have that working.. unfortunately something was chnaged that
prevented it.

On Mon, Nov 13, 2017 at 2:34 PM, Spaction <[hidden email]> wrote:

> User guide states that upgrading between versions should be as simple as
> changing the Artemis version in the etc/artemis.profile file.
>
> There are several differences between 2.4 and 2.3 that make this not
> possible.
>
> 2.4 requires etc/management.xml to be created.
> Additionally jolokia-access.xml is created but not required.
>
> bootstrap.xml needs the web section updated to remove the url="jolokia"
> line.
>
> Additionally after updating and adding, starting up of the service then
> reports insufficient roles/credentials everywhere on the jolokia UI when
> accessing remotely (cannot test locally as running on a linux box).
>
> This is the same when using the 2.4 instance instead of the upgraded one
> when trying to view anything remotely from the
>
> Please update the documentation to correctly indicate how to upgrade Artemis
> versions.
>
>
>
> --
> Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html



--
Clebert Suconic