ApacheMQ Artemis and Support for JGroups 4.x

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

ApacheMQ Artemis and Support for JGroups 4.x

erie14
Was wondering when ApacheMQ Artemis plans to upgrade to JGroups 4.x?  



--
Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html
Reply | Threaded
Open this post in threaded view
|

Re: ApacheMQ Artemis and Support for JGroups 4.x

jbertram
I don't believe there are any plans to move to JGroups 4.x.  Is there a
particular reason why upgrading would be beneficial?


Justin

On Wed, Nov 1, 2017 at 7:12 AM, erie14 <[hidden email]> wrote:

> Was wondering when ApacheMQ Artemis plans to upgrade to JGroups 4.x?
>
>
>
> --
> Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-
> f2341805.html
>
Reply | Threaded
Open this post in threaded view
|

Re: ApacheMQ Artemis and Support for JGroups 4.x

erie14
Yes absolutely, besides the obvious (upgrade to most supported version of
JGroups),  i run artemis in a kubernetes cluster and i need clustering pods
to communicate over TCP.  Currently,  i have gotten it to work using JGroups
3.x with a JGroups Extra for Kuberentes (
https://github.com/jgroups-extras/jgroups-kubernetes ).  The problem is the
JGroups Kubernetes will no longer support JGroups 3.x.  I am currently using
an unsupported JGroups kubernetes for it to work within artemis.  

On another note,  i was thinking of pushing this configuration to github as
a new repository.  Do you think it would be beneficial to do so?  Its really
just a docker file and some scripts to get it working with JGroups.

V/r
Ed



--
Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html
Reply | Threaded
Open this post in threaded view
|

Re: ApacheMQ Artemis and Support for JGroups 4.x

Justin Bertram
Please open a JIRA [1] describing the upgrade you want and why.  Thanks!


Justin

[1] https://issues.apache.org/jira/browse/ARTEMIS

On Wed, Nov 1, 2017 at 11:48 AM, erie14 <[hidden email]> wrote:

> Yes absolutely, besides the obvious (upgrade to most supported version of
> JGroups),  i run artemis in a kubernetes cluster and i need clustering pods
> to communicate over TCP.  Currently,  i have gotten it to work using
> JGroups
> 3.x with a JGroups Extra for Kuberentes (
> https://github.com/jgroups-extras/jgroups-kubernetes ).  The problem is
> the
> JGroups Kubernetes will no longer support JGroups 3.x.  I am currently
> using
> an unsupported JGroups kubernetes for it to work within artemis.
>
> On another note,  i was thinking of pushing this configuration to github as
> a new repository.  Do you think it would be beneficial to do so?  Its
> really
> just a docker file and some scripts to get it working with JGroups.
>
> V/r
> Ed
>
>
>
> --
> Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-
> f2341805.html
>