Apache Stomp, Apollo broker, nodejs client works fine, NMS client disconnecting?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Apache Stomp, Apollo broker, nodejs client works fine, NMS client disconnecting?

BugVito
Hi All,
I have an Apollo Broker set up, it's been running solid for 2 months without any hiccups. I also have a nodejs client monitoring a specific topic (the only one I talk about in this post).  The nodejs receives all messages on the topic without any issues, although the NMS Stomp consumer stop receiving messages randomly.  I cannot say that it's after 30 seconds, or a specific amount of time, it simply stops.  I do not see any disconnect.

Would anyone have any idea what I may have missed? I'm using vanilla configs as much as possible, I'm using the same username and password everywhere, and as I said, the nodejs consumer works fine, but NMS consumer stops receiving messages.

I'm using NMS.STOMP 1.5.2.

Thanks!
Reply | Threaded
Open this post in threaded view
|

Re: Apache Stomp, Apollo broker, nodejs client works fine, NMS client disconnecting?

BugVito
OK Finally a bit more debugging info:

On the client side:
Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.

On the Apollo side:
2012-04-18 14:13:16,293 Shutting connection '/10.10.21.200:54398'  down due to: java.io.IOException: Unable to parser header line [ascii: ACK]
2012-04-18 14:13:16,294 disconnected: local:/10.10.23.70:61613, remote:/10.10.21.200:54398

I am using Stomp.NMS 1.5.2, and though that this issue was resolved from 1.5.1.

Any ideas at all? I'm running short on ideas, any help would be appreciated.