Apache NMS and Visual Studio C# 2010 Express

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Apache NMS and Visual Studio C# 2010 Express

fziska
This post has NOT been accepted by the mailing list yet.
Dear all,

I am currently trying to test a C# client with the NMS Api .dlls. But I am facing some conflicts which I don’t know how to solve.

My settings are following:
• .Net Target Framework 4.0 Client Profile
• Apache.nms-1.5.0.dll
• Apache.nms.ActiveMQ-1.5.2.dll

When I am trying to build my client I get following conflict:

Assembly “Apache.NMS.ActiveMQ” couldn’t be solved because it has a dependency to System.Web, Version=4.0.0.0 which doesn’t exists in the target framework.

Same for Apache.NMS.

I already googled for hours to find a hint how to solve this issue but i didn't find anything.
I hope somebody can help me !?

Regards
Reply | Threaded
Open this post in threaded view
|

Re: Apache NMS and Visual Studio C# 2010 Express

fziska
Solved the issues by changing the target framework from ".Net 4 Client Profile" to just ".Net 4" helped. I can build the project now!