Apache.NMS.ActiveMQ v1.4.1 and Durable Subscription message loss

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Apache.NMS.ActiveMQ v1.4.1 and Durable Subscription message loss

magellings
I have an NUnit unit test which proves message loss with a durable subscriber when using version 1.4.1 with ActiveMQ version 5.4.1.  

The same unit tests passes when using NMS v1.1.0.

The message loss occurs when the master broker fails over to the slave broker.

Like I said I have the unit test, but what else should I all include when I create an issue for this?  ActiveMQ configuration?  Anything else that could help with troubleshooting the issue?

Reply | Threaded
Open this post in threaded view
|

Re: Apache.NMS.ActiveMQ v1.4.1 and Durable Subscription message loss

jgomes
Thanks for creating that test!  I think the ActiveMQ server configuration is
necessary if it requires anything special to reproduce, otherwise, just
mention that the server has a standard configuration.  Also include any URI
parameter options necessary for the client.

On Wed, Nov 24, 2010 at 2:44 PM, magellings <[hidden email]> wrote:

>
> I have an NUnit unit test which proves message loss with a durable
> subscriber
> when using version 1.4.1 with ActiveMQ version 5.4.1.
>
> The same unit tests passes when using NMS v1.1.0.
>
> The message loss occurs when the master broker fails over to the slave
> broker.
>
> Like I said I have the unit test, but what else should I all include when I
> create an issue for this?  ActiveMQ configuration?  Anything else that
> could
> help with troubleshooting the issue?
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/Apache-NMS-ActiveMQ-v1-4-1-and-Durable-Subscription-message-loss-tp3058202p3058202.html
> Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: Apache.NMS.ActiveMQ v1.4.1 and Durable Subscription message loss

magellings
Is it possible this is an issue with ActiveMQ 5.4.1 despite an older version of NMS working fine?

Gary found an issue with the latest cut which is highly related.  He mentions it here:  http://activemq.2283324.n4.nabble.com/VOTE-Apache-ActiveMQ-5-4-2-td3058930.html#a3060530 
Reply | Threaded
Open this post in threaded view
|

Re: Apache.NMS.ActiveMQ v1.4.1 and Durable Subscription message loss

jgomes
That's an interesting thought.  It's possible that a server bug is exposed
by the client being more compliant with the spec.  I guess we can check with
the latest cut of the server that was done today.
On Nov 26, 2010 8:09 AM, "magellings" <[hidden email]> wrote:
>
> Is it possible this is an issue with ActiveMQ 5.4.1 despite an older
version
> of NMS working fine?
>
> Gary found an issue with the latest cut which is highly related. He
> mentions it here:
>
http://activemq.2283324.n4.nabble.com/VOTE-Apache-ActiveMQ-5-4-2-td3058930.html#a3060530
> --
> View this message in context:
http://activemq.2283324.n4.nabble.com/Apache-NMS-ActiveMQ-v1-4-1-and-Durable-Subscription-message-loss-tp3058202p3060536.html
> Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
Reply | Threaded
Open this post in threaded view
|

Re: Apache.NMS.ActiveMQ v1.4.1 and Durable Subscription message loss

magellings
Issue created here: https://issues.apache.org/activemq/browse/AMQNET-294 

It would be great if we could get a patch ASAP as we have been thoroughly testing ActiveMQ v5.4.1 with NMS and this specifically is holding us up on our migration.

Thanks for your attention!

-Mark