ActiveMQ Artemis: Durable Message in durable Queue

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

ActiveMQ Artemis: Durable Message in durable Queue

andi welchlin
Hello all,

I have configured one queue in Artemis which is durable.
I sent a durable message to this queue and would have expected to see this
message even if the consumer connects later than the message was published.
But this is not the case in my test.

I configured the queue like:

 <queues>
       <queue name="awe.test.queue">
          <address>awe.test.queue</address>
          <durable>true</durable>
        </queue>
    </queues>


... and sent a message using durable with AMQP 1.0 using the qpid-sender
from qpid cpp package.

qpid-send -b localhost:9800 -a awe.test.queue
'--connection-option={protocol:amqp1.0}' --content-string 'test message Di
12. Dez 09:32:47 CET 2017' --durable=yes


As long as the receiver is connected it receives the message but when it
joins later, then nothing happens.

Did I miss some point in my configuration?

Kind Regards,
Andreas

PS: Test was done using only one broker.
Reply | Threaded
Open this post in threaded view
|

Re: ActiveMQ Artemis: Durable Message in durable Queue

clebertsuconic
Why don't you use the new format...


the <queues> exist for backward compatibility:


<addresses>
   <address name="test.queue">
      <anycast>
         <queue name="test.queue"/>
      </anycast>
   </address>
   <address name="exampleQueue">
      <anycast>
         <queue name="exampleQueue"/>
      </anycast>
   </address>
</addresses>





On Tue, Dec 12, 2017 at 10:11 AM, andi welchlin <[hidden email]> wrote:

> Hello all,
>
> I have configured one queue in Artemis which is durable.
> I sent a durable message to this queue and would have expected to see this
> message even if the consumer connects later than the message was published.
> But this is not the case in my test.
>
> I configured the queue like:
>
>  <queues>
>        <queue name="awe.test.queue">
>           <address>awe.test.queue</address>
>           <durable>true</durable>
>         </queue>
>     </queues>
>
>
> ... and sent a message using durable with AMQP 1.0 using the qpid-sender
> from qpid cpp package.
>
> qpid-send -b localhost:9800 -a awe.test.queue
> '--connection-option={protocol:amqp1.0}' --content-string 'test message Di
> 12. Dez 09:32:47 CET 2017' --durable=yes
>
>
> As long as the receiver is connected it receives the message but when it
> joins later, then nothing happens.
>
> Did I miss some point in my configuration?
>
> Kind Regards,
> Andreas
>
> PS: Test was done using only one broker.



--
Clebert Suconic
Reply | Threaded
Open this post in threaded view
|

Re: ActiveMQ Artemis: Durable Message in durable Queue

andi welchlin
Hi Clebert,

this was just because I did not know that there is a new and an old format.

I changed it to the new format and everything works fine, with and without
cluster.

Thank you!

Kind Regards,
Andreas

PS: config looks like this, now:

    <addresses>
         <address name="ttt.test.queue">
            <anycast>
               <queue name="ttt.test.queue">
                   <durable>true</durable>
               </queue>
            </anycast>
         </address>
      </addresses>



On Tue, Dec 12, 2017 at 5:23 PM, Clebert Suconic <[hidden email]>
wrote:

> Why don't you use the new format...
>
>
> the <queues> exist for backward compatibility:
>
>
> <addresses>
>    <address name="test.queue">
>       <anycast>
>          <queue name="test.queue"/>
>       </anycast>
>    </address>
>    <address name="exampleQueue">
>       <anycast>
>          <queue name="exampleQueue"/>
>       </anycast>
>    </address>
> </addresses>
>
>
>
>
>
> On Tue, Dec 12, 2017 at 10:11 AM, andi welchlin <[hidden email]>
> wrote:
> > Hello all,
> >
> > I have configured one queue in Artemis which is durable.
> > I sent a durable message to this queue and would have expected to see
> this
> > message even if the consumer connects later than the message was
> published.
> > But this is not the case in my test.
> >
> > I configured the queue like:
> >
> >  <queues>
> >        <queue name="awe.test.queue">
> >           <address>awe.test.queue</address>
> >           <durable>true</durable>
> >         </queue>
> >     </queues>
> >
> >
> > ... and sent a message using durable with AMQP 1.0 using the qpid-sender
> > from qpid cpp package.
> >
> > qpid-send -b localhost:9800 -a awe.test.queue
> > '--connection-option={protocol:amqp1.0}' --content-string 'test message
> Di
> > 12. Dez 09:32:47 CET 2017' --durable=yes
> >
> >
> > As long as the receiver is connected it receives the message but when it
> > joins later, then nothing happens.
> >
> > Did I miss some point in my configuration?
> >
> > Kind Regards,
> > Andreas
> >
> > PS: Test was done using only one broker.
>
>
>
> --
> Clebert Suconic
>