ActiveMQ 5.9 supported operating system

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

ActiveMQ 5.9 supported operating system

Roy Low Chee Mun
hi all


wondering can ActiveMQ 5.9 install in Windows server 2012? because in the
list i dont see windows server 2012 is in the supported operating system
lists, i am referring to link below


https://activemq.apache.org/getting-started


`Operating Systems:**

Windows: Windows XP SP2, Windows 2000, Windows Vista, Windows 7.



--
Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html
Reply | Threaded
Open this post in threaded view
|

Re: ActiveMQ 5.9 supported operating system

Tim Bain
ActiveMQ runs in a Java Runtime Environment (JRE). 5.9 requires Java 7 or
later for its JRE. If you can run a Java 7 JRE on Windows Server 2012, then
you can run ActiveMQ on it.

Tim

On Mon, Jan 20, 2020, 7:12 PM Roy Low Chee Mun <[hidden email]> wrote:

> hi all
>
>
> wondering can ActiveMQ 5.9 install in Windows server 2012? because in the
> list i dont see windows server 2012 is in the supported operating system
> lists, i am referring to link below
>
>
> https://activemq.apache.org/getting-started
>
>
> `Operating Systems:**
>
> Windows: Windows XP SP2, Windows 2000, Windows Vista, Windows 7.
>
>
>
> --
> Sent from:
> http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html
>
Reply | Threaded
Open this post in threaded view
|

Re: ActiveMQ 5.9 supported operating system

jbertram
In reply to this post by Roy Low Chee Mun
I don't think that documentation has been updated in a *long* time, but I
don't think there's any need to worry about installing ActiveMQ 5.x on
Windows Server 2012. As long as you can get the right JVM for your platform
it should be fine. For ActiveMQ 5.9.0 (which is pretty old at this point,
not sure why you'd want to use it) it looks like you'll need Java 6.


Justin

On Mon, Jan 20, 2020 at 8:12 PM Roy Low Chee Mun <[hidden email]>
wrote:

> hi all
>
>
> wondering can ActiveMQ 5.9 install in Windows server 2012? because in the
> list i dont see windows server 2012 is in the supported operating system
> lists, i am referring to link below
>
>
> https://activemq.apache.org/getting-started
>
>
> `Operating Systems:**
>
> Windows: Windows XP SP2, Windows 2000, Windows Vista, Windows 7.
>
>
>
> --
> Sent from:
> http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html
>
>
Reply | Threaded
Open this post in threaded view
|

Re: ActiveMQ 5.9 supported operating system

jbertram
In reply to this post by Tim Bain
BTW, I based my Java 6 recommendation on this [1] from the 5.9.0 tag.


Justin

[1] https://github.com/apache/activemq/blob/activemq-5.9.0/pom.xml#L138

On Mon, Jan 20, 2020 at 10:02 PM Tim Bain <[hidden email]> wrote:

> ActiveMQ runs in a Java Runtime Environment (JRE). 5.9 requires Java 7 or
> later for its JRE. If you can run a Java 7 JRE on Windows Server 2012, then
> you can run ActiveMQ on it.
>
> Tim
>
> On Mon, Jan 20, 2020, 7:12 PM Roy Low Chee Mun <[hidden email]>
> wrote:
>
> > hi all
> >
> >
> > wondering can ActiveMQ 5.9 install in Windows server 2012? because in the
> > list i dont see windows server 2012 is in the supported operating system
> > lists, i am referring to link below
> >
> >
> > https://activemq.apache.org/getting-started
> >
> >
> > `Operating Systems:**
> >
> > Windows: Windows XP SP2, Windows 2000, Windows Vista, Windows 7.
> >
> >
> >
> > --
> > Sent from:
> > http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: ActiveMQ 5.9 supported operating system

Roy Low Chee Mun
In reply to this post by Tim Bain
thank you everyone, so i will check what is java version required for
ActiveMQ 5.9 and whether can installed on windows server 2012 or not, thank
you very much everyone



--
Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html