ActiveMQ 5.9.0 Hawtio Slow

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

ActiveMQ 5.9.0 Hawtio Slow

kraythe
I downloaded ActiveMQ 5.9.0 with Hawtio (in research to ugrade from 5.8.0) and I am experiencing such slowness in the console that it is unusable. Any click takes up to a second for a reply. Any idea what I have configured wrong? Or is it just not ready for prime time? Thanks in advance.
Reply | Threaded
Open this post in threaded view
|

Re: ActiveMQ 5.9.0 Hawtio Slow

ceposta
i haven't noticed anything like this.
what OS/browser are you using?

On Sun, Jan 5, 2014 at 9:41 PM, kraythe <[hidden email]> wrote:

> I downloaded ActiveMQ 5.9.0 with Hawtio (in research to ugrade from 5.8.0)
> and I am experiencing such slowness in the console that it is unusable. Any
> click takes up to a second for a reply. Any idea what I have configured
> wrong? Or is it just not ready for prime time? Thanks in advance.
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-5-9-0-Hawtio-Slow-tp4676028.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.



--
Christian Posta
http://www.christianposta.com/blog
twitter: @christianposta
Reply | Threaded
Open this post in threaded view
|

Re: ActiveMQ 5.9.0 Hawtio Slow

James Strachan-2
You might want to tone down the refresh rate on the Preferences page to see
if that helps?


On 8 January 2014 17:37, Christian Posta <[hidden email]> wrote:

> i haven't noticed anything like this.
> what OS/browser are you using?
>
> On Sun, Jan 5, 2014 at 9:41 PM, kraythe <[hidden email]> wrote:
> > I downloaded ActiveMQ 5.9.0 with Hawtio (in research to ugrade from
> 5.8.0)
> > and I am experiencing such slowness in the console that it is unusable.
> Any
> > click takes up to a second for a reply. Any idea what I have configured
> > wrong? Or is it just not ready for prime time? Thanks in advance.
> >
> >
> >
> > --
> > View this message in context:
> http://activemq.2283324.n4.nabble.com/ActiveMQ-5-9-0-Hawtio-Slow-tp4676028.html
> > Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>
>
> --
> Christian Posta
> http://www.christianposta.com/blog
> twitter: @christianposta
>



--
James
-------
Red Hat

Email: [hidden email]
Web: http://fusesource.com
Twitter: jstrachan, fusenews
Blog: http://macstrac.blogspot.com/

Open Source Integration
Reply | Threaded
Open this post in threaded view
|

Re: ActiveMQ 5.9.0 Hawtio Slow

kraythe
Actually I have it set at the max of 30 seconds and it still runs agonizingly slow taking 30+ seconds to load a page. 

Robert Simmons Jr. MSc. - Lead Java Architect @ EA
Author of: Hardcore Java (2003) and Maintainable Java (2012)


On Wed, Jan 8, 2014 at 11:40 AM, James Strachan-2 [via ActiveMQ] <[hidden email]> wrote:
You might want to tone down the refresh rate on the Preferences page to see
if that helps?


On 8 January 2014 17:37, Christian Posta <[hidden email]> wrote:

> i haven't noticed anything like this.
> what OS/browser are you using?
>
> On Sun, Jan 5, 2014 at 9:41 PM, kraythe <[hidden email]> wrote:

> > I downloaded ActiveMQ 5.9.0 with Hawtio (in research to ugrade from
> 5.8.0)
> > and I am experiencing such slowness in the console that it is unusable.
> Any
> > click takes up to a second for a reply. Any idea what I have configured
> > wrong? Or is it just not ready for prime time? Thanks in advance.
> >
> >
> >
> > --
> > View this message in context:
> http://activemq.2283324.n4.nabble.com/ActiveMQ-5-9-0-Hawtio-Slow-tp4676028.html
> > Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>
>
> --
> Christian Posta
> http://www.christianposta.com/blog
> twitter: @christianposta
>



--
James
-------
Red Hat

Email: [hidden email]
Web: http://fusesource.com
Twitter: jstrachan, fusenews
Blog: http://macstrac.blogspot.com/

Open Source Integration



If you reply to this email, your message will be added to the discussion below:
http://activemq.2283324.n4.nabble.com/ActiveMQ-5-9-0-Hawtio-Slow-tp4676028p4676121.html
To unsubscribe from ActiveMQ 5.9.0 Hawtio Slow, click here.
NAML

Reply | Threaded
Open this post in threaded view
|

Re: ActiveMQ 5.9.0 Hawtio Slow

kraythe
I figured this out. If I access it via localhost:8161 it is extremely slow
but if I use my local IP then it is very fast. Bug time I think.

*Robert Simmons Jr. MSc. - Lead Java Architect @ EA*
*Author of: Hardcore Java (2003) and Maintainable Java (2012)*
*LinkedIn: **http://www.linkedin.com/pub/robert-simmons/40/852/a39
<http://www.linkedin.com/pub/robert-simmons/40/852/a39>*


On Fri, Jan 10, 2014 at 2:24 PM, kraythe . <[hidden email]> wrote:

> Actually I have it set at the max of 30 seconds and it still runs
> agonizingly slow taking 30+ seconds to load a page.
>
> *Robert Simmons Jr. MSc. - Lead Java Architect @ EA*
> *Author of: Hardcore Java (2003) and Maintainable Java (2012)*
> *LinkedIn: **http://www.linkedin.com/pub/robert-simmons/40/852/a39
> <http://www.linkedin.com/pub/robert-simmons/40/852/a39>*
>
>
> On Wed, Jan 8, 2014 at 11:40 AM, James Strachan-2 [via ActiveMQ] <
> [hidden email]> wrote:
>
>> You might want to tone down the refresh rate on the Preferences page to
>> see
>> if that helps?
>>
>>
>> On 8 January 2014 17:37, Christian Posta <[hidden email]<http://user/SendEmail.jtp?type=node&node=4676121&i=0>>
>> wrote:
>>
>> > i haven't noticed anything like this.
>> > what OS/browser are you using?
>> >
>> > On Sun, Jan 5, 2014 at 9:41 PM, kraythe <[hidden email]<http://user/SendEmail.jtp?type=node&node=4676121&i=1>>
>> wrote:
>> > > I downloaded ActiveMQ 5.9.0 with Hawtio (in research to ugrade from
>> > 5.8.0)
>> > > and I am experiencing such slowness in the console that it is
>> unusable.
>> > Any
>> > > click takes up to a second for a reply. Any idea what I have
>> configured
>> > > wrong? Or is it just not ready for prime time? Thanks in advance.
>> > >
>> > >
>> > >
>> > > --
>> > > View this message in context:
>> >
>> http://activemq.2283324.n4.nabble.com/ActiveMQ-5-9-0-Hawtio-Slow-tp4676028.html
>> > > Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>> >
>> >
>> >
>> > --
>> > Christian Posta
>> > http://www.christianposta.com/blog
>> > twitter: @christianposta
>> >
>>
>>
>>
>> --
>> James
>> -------
>> Red Hat
>>
>> Email: [hidden email]<http://user/SendEmail.jtp?type=node&node=4676121&i=2>
>> Web: http://fusesource.com
>> Twitter: jstrachan, fusenews
>> Blog: http://macstrac.blogspot.com/
>>
>> Open Source Integration
>>
>>
>> ------------------------------
>>  If you reply to this email, your message will be added to the
>> discussion below:
>>
>> http://activemq.2283324.n4.nabble.com/ActiveMQ-5-9-0-Hawtio-Slow-tp4676028p4676121.html
>>  To unsubscribe from ActiveMQ 5.9.0 Hawtio Slow, click here<
>> .
>> NAML<
http://activemq.2283324.n4.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>
>>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: ActiveMQ 5.9.0 Hawtio Slow

James Strachan-2
Aha! Thanks for the heads up. Sounds like something odd with your network
configuration maybe? Is 127.0.0.1 slow too?

On Friday, January 10, 2014, kraythe . wrote:

> I figured this out. If I access it via localhost:8161 it is extremely slow
> but if I use my local IP then it is very fast. Bug time I think.
>
> *Robert Simmons Jr. MSc. - Lead Java Architect @ EA*
> *Author of: Hardcore Java (2003) and Maintainable Java (2012)*
> *LinkedIn: **http://www.linkedin.com/pub/robert-simmons/40/852/a39
> <http://www.linkedin.com/pub/robert-simmons/40/852/a39>*
>
>
> On Fri, Jan 10, 2014 at 2:24 PM, kraythe . <[hidden email]> wrote:
>
> > Actually I have it set at the max of 30 seconds and it still runs
> > agonizingly slow taking 30+ seconds to load a page.
> >
> > *Robert Simmons Jr. MSc. - Lead Java Architect @ EA*
> > *Author of: Hardcore Java (2003) and Maintainable Java (2012)*
> > *LinkedIn: **http://www.linkedin.com/pub/robert-simmons/40/852/a39
> > <http://www.linkedin.com/pub/robert-simmons/40/852/a39>*
> >
> >
> > On Wed, Jan 8, 2014 at 11:40 AM, James Strachan-2 [via ActiveMQ] <
> > [hidden email]> wrote:
> >
> >> You might want to tone down the refresh rate on the Preferences page to
> >> see
> >> if that helps?
> >>
> >>
> >> On 8 January 2014 17:37, Christian Posta <[hidden email]<
> http://user/SendEmail.jtp?type=node&node=4676121&i=0>>
> >> wrote:
> >>
> >> > i haven't noticed anything like this.
> >> > what OS/browser are you using?
> >> >
> >> > On Sun, Jan 5, 2014 at 9:41 PM, kraythe <[hidden email]<
> http://user/SendEmail.jtp?type=node&node=4676121&i=1>>
> >> wrote:
> >> > > I downloaded ActiveMQ 5.9.0 with Hawtio (in research to ugrade from
> >> > 5.8.0)
> >> > > and I am experiencing such slowness in the console that it is
> >> unusable.
> >> > Any
> >> > > click takes up to a second for a reply. Any idea what I have
> >> configured
> >> > > wrong? Or is it just not ready for prime time? Thanks in advance.
> >> > >
> >> > >
> >> > >
> >> > > --
> >> > > View this message in context:
> >> >
> >>
> http://activemq.2283324.n4.nabble.com/ActiveMQ-5-9-0-Hawtio-Slow-tp4676028.html
> >> > > Sent from the ActiveMQ - User mailing list archive at Nabble.com.
> >> >
> >> >
> >> >
> >> > --
> >> > Christian Posta
> >> > http://www.christianposta.com/blog
> >> > twitter: @christianposta
> >> >
> >>
> >>
> >>
> >> --
> >> James
> >> -------
> >> Red Hat
> >>
> >> Email: [hidden email]<
> http://user/SendEmail.jtp?type=node&node=4676121&i=2>
> >> Web: http://fusesource.com
> >> Twitter: jstrachan, fusenews
> >> Blog: http://macstrac.blogspot.com/
> >>
> >> Open Source Integration
> >>
> >>
> >> ------------------------------
> >>  If you reply to this email, your message will be added to the
> >> discussion below:
> >>
> >>
> http://activemq.2283324.n4.nabble.com/ActiveMQ-5-9-0-Hawtio-Slow-tp4676028p4676121.html
> >>  To unsubscribe from ActiveMQ 5.9.0 Hawtio Slow, click here<
> >
> >> .
> >> NAML<<
http://activemq.2283324.n4.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>



--
James
-------
Red Hat

Email: [hidden email]
Web: http://fusesource.com
Twitter: jstrachan, fusenews
Blog: http://macstrac.blogspot.com/

Open Source Integration
Reply | Threaded
Open this post in threaded view
|

Re: ActiveMQ 5.9.0 Hawtio Slow

kraythe
Actually accessing on loop back is fine. And my /etc/hosts/private on my Mac is set up correctly. I think it must be some bug where the Hawtio is trying to do some DNS resolution or something and had to time out or something. Never seen a JavaScript app do this before so I am sort of guessing.


On Saturday, January 11, 2014, James Strachan-2 [via ActiveMQ] wrote:
Aha! Thanks for the heads up. Sounds like something odd with your network
configuration maybe? Is 127.0.0.1 slow too?

On Friday, January 10, 2014, kraythe . wrote:

> I figured this out. If I access it via localhost:8161 it is extremely slow
> but if I use my local IP then it is very fast. Bug time I think.
>
> *Robert Simmons Jr. MSc. - Lead Java Architect @ EA*
> *Author of: Hardcore Java (2003) and Maintainable Java (2012)*
> *LinkedIn: **http://www.linkedin.com/pub/robert-simmons/40/852/a39
> <http://www.linkedin.com/pub/robert-simmons/40/852/a39>*
>
>
> On Fri, Jan 10, 2014 at 2:24 PM, kraythe . <[hidden email]> wrote:
>
> > Actually I have it set at the max of 30 seconds and it still runs
> > agonizingly slow taking 30+ seconds to load a page.
> >
> > *Robert Simmons Jr. MSc. - Lead Java Architect @ EA*
> > *Author of: Hardcore Java (2003) and Maintainable Java (2012)*
> > *LinkedIn: **http://www.linkedin.com/pub/robert-simmons/40/852/a39
> > <http://www.linkedin.com/pub/robert-simmons/40/852/a39>*
> >
> >
> > On Wed, Jan 8, 2014 at 11:40 AM, James Strachan-2 [via ActiveMQ] <
> > [hidden email]> wrote:
> >
> >> You might want to tone down the refresh rate on the Preferences page to
> >> see
> >> if that helps?
> >>
> >>
> >> On 8 January 2014 17:37, Christian Posta <[hidden email]<
> http://user/SendEmail.jtp?type=node&node=4676121&i=0>>
> >> wrote:
> >>
> >> > i haven't noticed anything like this.
> >> > what OS/browser are you using?
> >> >
> >> > On Sun, Jan 5, 2014 at 9:41 PM, kraythe <[hidden email]<
> http://user/SendEmail.jtp?type=node&node=4676121&i=1>>
> >> wrote:
> >> > > I downloaded ActiveMQ 5.9.0 with Hawtio (in research to ugrade from
> >> > 5.8.0)
> >> > > and I am experiencing such slowness in the console that it is
> >> unusable.
> >> > Any
> >> > > click takes up to a second for a reply. Any idea what I have
> >> configured
> >> > > wrong? Or is it just not ready for prime time? Thanks in advance.
> >> > >
> >> > >
> >> > >
> >> > > --
> >> > > View this message in context:
> >> >
> >>
> http://activemq.2283324.n4.nabble.com/ActiveMQ-5-9-0-Hawtio-Slow-tp4676028.html
> >> > > Sent from the ActiveMQ - User mailing list archive at Nabble.com.

> >> >
> >> >
> >> >
> >> > --
> >> > Christian Posta
> >> > http://www.christianposta.com/blog
> >> > twitter: @christianposta
> >> >
> >>
> >>
> >>
> >> --
> >> James
> >> -------
> >> Red Hat
> >>
> >> Email: [hidden email]<
> http://user/SendEmail.jtp?type=node&node=4676121&i=2>
> >> Web: http://fusesource.com
> >> Twitter: jstrachan, fusenews
> >> Blog: http://macstrac.blogspot.com/
> >>
> >> Open Source Integration
> >>
> >>
> >> ------------------------------
> >>  If you reply to this email, your message will be added to the
> >> discussion below:
> >>
> >>
> http://activemq.2283324.n4.nabble.com/ActiveMQ-5-9-0-Hawtio-Slow-tp4676028p4676121.html
> >>  To unsubscribe from ActiveMQ 5.9.0 Hawtio Slow, click here<
> >
> >> .
> >> NAML<<
http://activemq.2283324.n4.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>



--
James
-------
Red Hat

Email: [hidden email]
Web: http://fusesource.com
Twitter: jstrachan, fusenews
Blog: http://macstrac.blogspot.com/

Open Source Integration



If you reply to this email, your message will be added to the discussion below:
http://activemq.2283324.n4.nabble.com/ActiveMQ-5-9-0-Hawtio-Slow-tp4676028p4676221.html
To unsubscribe from ActiveMQ 5.9.0 Hawtio Slow, click here.
NAML


--
Robert Simmons Jr. MSc. - Lead Java Architect @ EA
Author of: Hardcore Java (2003) and Maintainable Java (2012)

Reply | Threaded
Open this post in threaded view
|

Re: ActiveMQ 5.9.0 Hawtio Slow

fliot
Hi,

I got mostly the same behaviour.
Accessing by http://the.full.qualified.name.of.my.machine:8080/hawtio
is 20 times slower
than accessing by http://www.xx.yy.zz:8080/hawtio

My workstation : Ubuntu/Chromium or Firefox
My hawtio instance : Ubuntu/OracleJDK/Tomcat7/war embeded.

Regards,

Francois