AMQ-7149 - Remove dependency between activemq-http and activemq-stomp

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

AMQ-7149 - Remove dependency between activemq-http and activemq-stomp

jgallimore
Hi

I notice this ticket filed from a while ago -
https://issues.apache.org/jira/browse/AMQ-7149. Currently if you wish to
use the HTTP client, you need to make sure you have the stomp module on
your classpath, as the http module references the XStreamSupport class.

I've attempted to pull the patch on the ticket into 2 PRs, 1 for master,
and one for the 5.15.x branch.

Is this a change the community could consider? I'd welcome and review and
I'm happy to make any changes.

Many thanks

Jon