ACtivemq 5.10 compatibility

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

ACtivemq 5.10 compatibility

khandelwalanuj
Hi,

Previously I was using activemq 5.8 and all clients were using 5.8 and 5.5 for clients library.
I am trying to upgrade my broker to activemq 5.10. Are there any compatibility issue with new version ?
Will clients with Activemq 5.8 and 5.5 be able to run properly with broker running eith 5.10 ?
Reply | Threaded
Open this post in threaded view
|

Re: ACtivemq 5.10 compatibility

khandelwalanuj
Did anyone get a chance to look at this ?
Reply | Threaded
Open this post in threaded view
|

Re: ACtivemq 5.10 compatibility

surfnerd
We migrated from 5.8 to 5.10 without any problem.
Which protocol are you using ?
Reply | Threaded
Open this post in threaded view
|

Re: ACtivemq 5.10 compatibility

khandelwalanuj
I work in critical production environment. And I am switching my broker from 5.8 to 5.10. But clients will be keep on using 5.5/5.8 only for atleast 6 months.
I just want to make sure if there are there any sort of compatibility issues ?


Thanks,
Anuj
Reply | Threaded
Open this post in threaded view
|

Re: ACtivemq 5.10 compatibility

Petter Nordlander
Hi,

See release notes:  http://activemq.apache.org/activemq-5100-release.html
and http://activemq.apache.org/activemq-590-release.html

The text that you need to look at for 5.8-5.10 follows:

(AMQ 5.10)


Migration Guide  
* Removed
org.apache.activemq.camel.converter.IdentityMessageReuseConverter class
from the activemq-camel component.
‹‹‹‹‹

(AMQ 5.9)


There are some changes in 5.9 that may require user intervention
1. Schema change to JDBC Persistence Adapter. XID column type change.

* If you use XA transactions you need to ensure there are no XA
transactions pending completion before you upgrade. Some mode detail in
AMQ-4628 <https://issues.apache.org/jira/browse/AMQ-4628>


‹‹‹‹

However, there will always be a risk of new features and bug fixes that
might cause new bugs. I suggest you test your scenarios before switching
the live environment. Better safe than sorry!

BR Petter Nordlander



Den 2014-06-25 09:06 skrev khandelwalanuj <[hidden email]>:

>I work in critical production environment. And I am switching my broker
>from
>5.8 to 5.10. But clients will be keep on using 5.5/5.8 only for atleast 6
>months.
>I just want to make sure if there are there any sort of compatibility
>issues
>?
>
>
>Thanks,
>Anuj
>
>
>
>--
>View this message in context:
>http://activemq.2283324.n4.nabble.com/ACtivemq-5-10-compatibility-tp468224
>4p4682461.html
>Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Reply | Threaded
Open this post in threaded view
|

Re: ACtivemq 5.10 compatibility

gtully
I captured the same sentiments in a blog post a while back:
http://blog.garytully.com/2010/08/reminder-jms-is-client-server.html

On 25 June 2014 12:26, Petter Nordlander <[hidden email]> wrote:

> Hi,
>
> See release notes:  http://activemq.apache.org/activemq-5100-release.html
> and http://activemq.apache.org/activemq-590-release.html
>
> The text that you need to look at for 5.8-5.10 follows:
>
> (AMQ 5.10)
>
>
> Migration Guide
> * Removed
> org.apache.activemq.camel.converter.IdentityMessageReuseConverter class
> from the activemq-camel component.
> ‹‹‹‹‹
>
> (AMQ 5.9)
>
>
> There are some changes in 5.9 that may require user intervention
> 1. Schema change to JDBC Persistence Adapter. XID column type change.
>
> * If you use XA transactions you need to ensure there are no XA
> transactions pending completion before you upgrade. Some mode detail in
> AMQ-4628 <https://issues.apache.org/jira/browse/AMQ-4628>
>
>
> ‹‹‹‹
>
> However, there will always be a risk of new features and bug fixes that
> might cause new bugs. I suggest you test your scenarios before switching
> the live environment. Better safe than sorry!
>
> BR Petter Nordlander
>
>
>
> Den 2014-06-25 09:06 skrev khandelwalanuj <[hidden email]>:
>
>>I work in critical production environment. And I am switching my broker
>>from
>>5.8 to 5.10. But clients will be keep on using 5.5/5.8 only for atleast 6
>>months.
>>I just want to make sure if there are there any sort of compatibility
>>issues
>>?
>>
>>
>>Thanks,
>>Anuj
>>
>>
>>
>>--
>>View this message in context:
>>http://activemq.2283324.n4.nabble.com/ACtivemq-5-10-compatibility-tp468224
>>4p4682461.html
>>Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>



--
http://redhat.com
http://blog.garytully.com